Mandatory username change

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I'm an Advisor
Posts: 1,524

Re: Mandatory username change

Here it is a couple of days after implementing the user ID change and I still get an error message when I try logging into My Rogers. Why does Rogers continually have so much trouble with simple things like this? Time for someone at Rogers to dig into the guts of this stuff to figure out why this site is so mediocre.Smiley Mad

Highlighted
I'm a Senior Advisor
Posts: 3,689

Re: Mandatory username change

So far signing is with my username and password, as enabled by Firefox, has been working for me the last couple of days. Except, that is, the first time when the site prompted me to use my email address, which I thought was a bug and ignored. Since Rogers has all customers' email addresses, I'll wait for an official notification before making the switch.


Rogers PayGo. Location: S-W Ontario
Highlighted
I'm an Advisor
Posts: 1,524

Re: Mandatory username change


@OLDYELLR wrote:

So far signing is with my username and password, as enabled by Firefox, has been working for me the last couple of days. Except, that is, the first time when the site prompted me to use my email address, which I thought was a bug and ignored. Since Rogers has all customers' email addresses, I'll wait for an official notification before making the switch.


@OLDYELLR

 

I made the mistake of changing my user ID instead of ignoring it. It accepts it when I log in to My Rogers, but I only get the error message I posted earlier, both on my PC and iPhone. I also tried logging into Shomi because people are complaining about that and it rejected both of my user ID's. There's no excuse for stuff like this. Someone at Rogers should take a course in stress testing. I'm so ticked off with them, I'd gladly volunteer to do it myself for free. I was in IT for several decades and this kind of thing was second nature for me.

Highlighted
Resident Expert
Resident Expert
Posts: 14,261

Re: Mandatory username change

I still thing its something that flakes out when its DOING the conversion at times.


Mine changed over and works across all platforms, shomi, smarthome, etc



Highlighted
I'm an Advisor
Posts: 1,524

Re: Mandatory username change


@Gdkitty wrote:

I still thing its something that flakes out when its DOING the conversion at times.


Mine changed over and works across all platforms, shomi, smarthome, etc


@Gdkitty

 

That's interesting. Were you able to do the link to your account? I was not able to do it and got an error message. Since then, I have not had another request to perform the link. I'm thinking something may be wrong because it didn't complete. When I sign in, I still get the error message as posted earlier, plus also on my iPhone. My new user ID is working for everything except Shomi, which rejects both my old and new user ID.

Highlighted
Resident Expert
Resident Expert
Posts: 14,261

Re: Mandatory username change

I think thats right where the problem is..

 

HOW or WHY.. just account to account or by bug in the change over software... that its doing /asking for that link step.

 

 

When i did mine, it started going to the page where there was the 'enter your email to be used as your new login' page.

Entered and submitted it.

It went to a processing screen, with the bouncing lines... was there for a min or two..

Then went into the myrogers.

 

Never had to do any linking at all... whatever it did, it did it all on its own.



Highlighted
I'm an Advisor
Posts: 1,524

Re: Mandatory username change

@Gdkitty

 

OK, thanks for letting me know. I received a PM from a support person and described my problem saying I think the link not completing may be the problem. I sent them all my personal data so they can take a look at my account.

Highlighted
I'm an Advisor
Posts: 1,524

Re: Mandatory username change

And the beat goes on. Tried it again this morning and got the link account message. When I enter my info, I get a second message which tells me my account is already linked. There's an ignore this step option, but it does nothing. I end up right back at the same place, so it's impossible to get to my account. I've PM'ed Rogers to let them know about this latest problem. This sounds vaguely familiar from when Rogers first introduced this feature.

 

To make things more interesting, I logged in with the mobile app which also has a link option. It asked for my account number, as opposed to my wireless number, plus postal code. It accepted the account number and said my postal code is invalid. I first entered it with a blank in the middle, but the last digit wasn't accepted, so I reentered it without the space. The interesting thing is it showed me account wireless info. That is, everything to do with wireless, but nothing else.

Highlighted
I'm a Senior Advisor
Posts: 3,689

Re: Mandatory username change

Last night when I signed in, I briefly got another screen with my email address in the box where my usename appears and a box below, where my password would go asking me to confirm my email address, I think . But before I could read it all, it went to the forum where I was signed in. Then, this morning when I signed in, same thing. But this time I hit thee back button in my browser and went back and confirmed my email address. That gave me a popup to choose between my PayGo and Cable account and I chose the PayGo. I then clicked Community Forums at the bottom and here I am.

 

Just to see if anything got broken by confirming my email address, I opened my PayGo history bookmark in another tab and that worked. Next, I opened MYROGERS in another tab and chose my Cable account number from the dropdown and then clicked the VIEW BILL button at the bottom. Here is where it's now broken. I get zero balance because my cable bill is paid by pre-authorized chequing, but in the middle of the top row, where there was a window to select which of my bills I wanted to view, there was nothing, just "Bill history : " with no window below it. Now I can't see my previous, or any, cable bills and the messages attached to them. Please @RogersDarrell or somebody, how do we fix this mess?


Rogers PayGo. Location: S-W Ontario
Highlighted
I'm an Advisor
Posts: 1,524

Re: Mandatory username change

I think I may have found part of the problem. Right now, when I try to log in, I get the link overlay message which just sits there bouncing around. If I reply to a forum message by clicking on the email notification, it does it briefly, then goes to the forum.

 

After experimenting with different permutations and combinations of my account info, it appears that my 2 accounts, cable/internet and wireless, are now being treated differently. I've had my cable/internet account forever, but it was changed to a wireless account when I got my first cell phone about 7 years ago. Since then, my account has always been identified under the category of wireless. When I'm asked to provide a link on my computer, it shows an option for both cable/internet and wireless. Because I've had a wireless account designation for so long, I never think about using my old cable/internet account number. So, as an experiment, I entered it instead of wireless. It appeared to accept the account number, but it gave my postal code an error message saying that it's not the postal code they have on file, which is totally wrong. I think it's looking at old information from my cable/internet account and the postal code will certainly be something different from my current one. I've live in my current location for over 5 years and My Account has its postal code on record. When I tried to do a link on my iPhone, I entered my cable/internet account number because the app shows all my wireless info. When I entered the postal code, it told me it's invalid, so I'm guessing it's also looking for an old postal code. Of course, after so many years, I don't have a clue what the old one might be.

 

As of now, I still can't get to My Rogers. It's still stuck in the link loop.Smiley Mad