cancel
Showing results for 
Search instead for 
Did you mean: 

Mandatory username change

hiho
I Plan to Stick Around

went to login to My rogers and now am getting a thing where it needs to varify my email addy and that will be used as my username from now on....is this for real i have been using my current username for over 20yrs and now they want me to change it ?

 

not sure if this is for real or not since i havent seen any offical  email from rogers about this change? 

48 REPLIES 48

Re: Mandatory username change

OLDYELLR
I'm a Senior Advisor

So far signing is with my username and password, as enabled by Firefox, has been working for me the last couple of days. Except, that is, the first time when the site prompted me to use my email address, which I thought was a bug and ignored. Since Rogers has all customers' email addresses, I'll wait for an official notification before making the switch.


Rogers PayGo. Location: S-W Ontario

Re: Mandatory username change


@OLDYELLR wrote:

So far signing is with my username and password, as enabled by Firefox, has been working for me the last couple of days. Except, that is, the first time when the site prompted me to use my email address, which I thought was a bug and ignored. Since Rogers has all customers' email addresses, I'll wait for an official notification before making the switch.


@OLDYELLR

 

I made the mistake of changing my user ID instead of ignoring it. It accepts it when I log in to My Rogers, but I only get the error message I posted earlier, both on my PC and iPhone. I also tried logging into Shomi because people are complaining about that and it rejected both of my user ID's. There's no excuse for stuff like this. Someone at Rogers should take a course in stress testing. I'm so ticked off with them, I'd gladly volunteer to do it myself for free. I was in IT for several decades and this kind of thing was second nature for me.

Re: Mandatory username change

I still thing its something that flakes out when its DOING the conversion at times.


Mine changed over and works across all platforms, shomi, smarthome, etc

Re: Mandatory username change


@Gdkitty wrote:

I still thing its something that flakes out when its DOING the conversion at times.


Mine changed over and works across all platforms, shomi, smarthome, etc


@Gdkitty

 

That's interesting. Were you able to do the link to your account? I was not able to do it and got an error message. Since then, I have not had another request to perform the link. I'm thinking something may be wrong because it didn't complete. When I sign in, I still get the error message as posted earlier, plus also on my iPhone. My new user ID is working for everything except Shomi, which rejects both my old and new user ID.

Re: Mandatory username change

I think thats right where the problem is..

 

HOW or WHY.. just account to account or by bug in the change over software... that its doing /asking for that link step.

 

 

When i did mine, it started going to the page where there was the 'enter your email to be used as your new login' page.

Entered and submitted it.

It went to a processing screen, with the bouncing lines... was there for a min or two..

Then went into the myrogers.

 

Never had to do any linking at all... whatever it did, it did it all on its own.

Re: Mandatory username change

@Gdkitty

 

OK, thanks for letting me know. I received a PM from a support person and described my problem saying I think the link not completing may be the problem. I sent them all my personal data so they can take a look at my account.

Re: Mandatory username change

And the beat goes on. Tried it again this morning and got the link account message. When I enter my info, I get a second message which tells me my account is already linked. There's an ignore this step option, but it does nothing. I end up right back at the same place, so it's impossible to get to my account. I've PM'ed Rogers to let them know about this latest problem. This sounds vaguely familiar from when Rogers first introduced this feature.

 

To make things more interesting, I logged in with the mobile app which also has a link option. It asked for my account number, as opposed to my wireless number, plus postal code. It accepted the account number and said my postal code is invalid. I first entered it with a blank in the middle, but the last digit wasn't accepted, so I reentered it without the space. The interesting thing is it showed me account wireless info. That is, everything to do with wireless, but nothing else.

Re: Mandatory username change

OLDYELLR
I'm a Senior Advisor

Last night when I signed in, I briefly got another screen with my email address in the box where my usename appears and a box below, where my password would go asking me to confirm my email address, I think . But before I could read it all, it went to the forum where I was signed in. Then, this morning when I signed in, same thing. But this time I hit thee back button in my browser and went back and confirmed my email address. That gave me a popup to choose between my PayGo and Cable account and I chose the PayGo. I then clicked Community Forums at the bottom and here I am.

 

Just to see if anything got broken by confirming my email address, I opened my PayGo history bookmark in another tab and that worked. Next, I opened MYROGERS in another tab and chose my Cable account number from the dropdown and then clicked the VIEW BILL button at the bottom. Here is where it's now broken. I get zero balance because my cable bill is paid by pre-authorized chequing, but in the middle of the top row, where there was a window to select which of my bills I wanted to view, there was nothing, just "Bill history : " with no window below it. Now I can't see my previous, or any, cable bills and the messages attached to them. Please @RogersDarrell or somebody, how do we fix this mess?


Rogers PayGo. Location: S-W Ontario

Re: Mandatory username change

I think I may have found part of the problem. Right now, when I try to log in, I get the link overlay message which just sits there bouncing around. If I reply to a forum message by clicking on the email notification, it does it briefly, then goes to the forum.

 

After experimenting with different permutations and combinations of my account info, it appears that my 2 accounts, cable/internet and wireless, are now being treated differently. I've had my cable/internet account forever, but it was changed to a wireless account when I got my first cell phone about 7 years ago. Since then, my account has always been identified under the category of wireless. When I'm asked to provide a link on my computer, it shows an option for both cable/internet and wireless. Because I've had a wireless account designation for so long, I never think about using my old cable/internet account number. So, as an experiment, I entered it instead of wireless. It appeared to accept the account number, but it gave my postal code an error message saying that it's not the postal code they have on file, which is totally wrong. I think it's looking at old information from my cable/internet account and the postal code will certainly be something different from my current one. I've live in my current location for over 5 years and My Account has its postal code on record. When I tried to do a link on my iPhone, I entered my cable/internet account number because the app shows all my wireless info. When I entered the postal code, it told me it's invalid, so I'm guessing it's also looking for an old postal code. Of course, after so many years, I don't have a clue what the old one might be.

 

As of now, I still can't get to My Rogers. It's still stuck in the link loop.Smiley Mad

Re: Mandatory username change

asakha
I've Been Around

About the same problem here...  Except I don't have NHL GameCenter...  I've been asked to enter my email as my new login name since MyRogers change its system.  Took 2 days for the system to accept the email.  Then, next day, no account linked to the profile, been on live chat for 1h30, transfered too much for nothing.  No one is able to get it fix.  They even created a new profile, deleting the other one in the process...  And still unable to see my account since it's linked to another profile, probably the first one I had use for years before being asked to change my logon name...  But which is now unnaccessible.  It seems your system is broken...

Re: Mandatory username change

OLDYELLR
I'm a Senior Advisor

Here is my advice, which I should have followed, but fell into the trap.

 

HOLD OFF CONFIRMING YOUR EMAIL ADDRESS UNTIL ROGERS HAS FIGURED IT OUT.

 

I now find that I can no longer access Manage PVR from my Rogers On Demand page link. I can't sign in with my username anymore and when I sign in with my email address and password I get this:

 

notfound.jpg

 

The mandatory change from username to email address has really broken the system. Try to hold off as long as you can or resign yourself to losing a lot of functionality.


Rogers PayGo. Location: S-W Ontario

Re: Mandatory username change

OLDYELLR
I'm a Senior Advisor

An update to this saga.

 

I received an email from Rogers verifying my login was changed from my username to my email address:

 

11/21/2015
Hello,
Your My Rogers username was recently changed to: xxxxx@xxxxxx.xxx
If you have any questions or need help, please visit our website or contact us at your convenience.
11/21/2015
Bonjour,
Votre nom d'utilisateur Mon Rogers a été changé récemment pour : xxxxx@xxxxxx.xxx
Si vous avez des questions ou avez besoin d'aide, veuillez consulter notre site Internet ou communiquer avec nous au moment qui vous convient.

 

The "contact us" link didn't work because it was a web address (http://support@rogers.com) not an email address and when I sent an email to support@rogers.com it bounced because Rogers doesn't want to receive emails anymore.

 

Anyway, my Manage PVR bookmark is now working, but viewing my cable bill is still gone. @CommunityHelps


Rogers PayGo. Location: S-W Ontario

Re: Mandatory username change

One thing I forgot to mention is that the mobile app also shows my account balance.  That's the most important thing to me because I paid my bill a couple of days ago, but couldn't see my account balance until today. The balance is zero, which is what I expected. As far as other things that I can't see right now, it's not an issue for me. My internet package has 550GB of data and I've never come anywhere near using it all up.

Re: Mandatory username change

Finally can sign in, but still in the link account loop. I'm convinced it's looking for my old cable/internet account number plus whatever postal code I had way back before changing my account to wireless. I'm exchanging PM's here and think it's close to being resolved. I can sign in to all my Rogers services, but not Shomi. There's still something wrong there.

Re: Mandatory username change

OLDYELLR
I'm a Senior Advisor

It seems to be working for me okay now. Also, signing into the forum doesn't sign me into MyRogers instead like it sometimes used to do and vice versa. I now only have to sign into the forum once and don't have to go looking for it.

 

As for linking accounts, I have not done that yet for fear it does something I can't undo.


Rogers PayGo. Location: S-W Ontario

Re: Mandatory username change

@OLDYELLR

 

If you haven't done the link account thing yet, I'm surprised you're not stuck in the "loop". I'm getting a link request every time I sign in to My Rogers. Cancelling it does nothing but take me back to the same screen every time. I haven't been able to see my account on my computer for the past week since I changed my user ID. I can see my wireless details with the mobile app on my iPhone, plus my account balance. I cannot see my cable and internet details. The mobile app is also looking for another link which I tried and got the postal code error message.

Re: Mandatory username change

OLDYELLR
I'm a Senior Advisor

@jimboden I do have an option in MyRogers > Services to link my "Wireless or Cable Account" and my "Pay As You Go Account". The first needs Account Number and Postal Code and the second needs Phone Number and 4-digit PIN. I have taken neither of these steps because it says they're optional and I don't know precisely what it will do and whether it's reversible if I don't like it.

 

Currently, after signing in to MyRogers I sometimes get a popup to choose between my Cable and PayGo accounts, but not always.  When I get to BILLS & PAYMENTS, I see two different screens for Cable and PayGo, depending which account I've chosen from the popup, i.e., there are 4 different screens. I don't know what kind of loop you're talking about, but I have situations where I can't get to my PayGo history and just keep getting a screen to add to the account instead. In that case I sign out, then sign in again and choose my PayGo account from the popup.

 

The only other thing that's changed is the detailed Profile page is gone where you could set marketing permissions.


Rogers PayGo. Location: S-W Ontario

Re: Mandatory username change

I finally managed to get out of the link account loop. I dug up a couple of old postal codes and one of them worked when I linked my old cable/internet account. After that, my account still shows my wireless account number and my current postal code, so there's definitiley something weird going on. Once I got past that, when I sign in, I get a bunch of vertical bars jumping up and down and they are doing nothing. The whole screen is flashing, including the options across the top of the screen. Even though I'm already logged in, I had to click several times on the My Rogers option at the top of the screen before my account details showed up. There's even a problem there as internet usage is not available. From there, I could not sign into the forum either. When I click on the Community link, it takes me to the forum, but I'm not signed and using the old profile trick didn't work either. When I click on sign in, it takes me back to the bouncing bars. I finally managed to sign in by using a separate URL for the forum, plus clicking on the link from one of the emails from the forum.

 

There sure are lots of strange things going on. I've notified the support person who's been PMing me about my latest findings.

Re: Mandatory username change

Just a bit more from my last post. The sign in process from My Rogers is inconsistent. I just signed in here by clicking on reply first, then signing in to My Rogers, which took me to this thread.

 

The one thing I wanted to clarify, which I didn't notice initially, is that my former wireless account has been renamed to cable/internet. It still uses the shorter wireless account number that I've had for years.

Re: Mandatory username change

Hello @asakha,

 

Thanks for reaching out to us. 

 

We would like the opportunity to take a deeper look into your MyRogers account and help you resolve the issue.

 

I’m going to send you both a private message from @CommunityHelps. Please check our message via the envelope icon that appears on the top right-hand side of your screen when you are logged in to the forums.

 

@RogersGabrielle

Re: Mandatory username change

Asakha1
I've Been Here Awhile

Is it possible to send your private message to "Asakha1" instead... Somehow my "Asakha" account isn't accessible anymore even if I used it to send the original message...

We Want Your Opinion
Would you be interested in becoming a Community Testing Lab member?
Topic Stats
  • 48 replies
  • 2575 views
  • 5 Likes
  • 13 in conversation