Internet drops when doing speed test! (internet extreme 45$ deal) - toronto

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Here Awhile
Posts: 4

Internet drops when doing speed test! (internet extreme 45$ deal) - toronto

hello peeps,

 

internet extreme (35mbps up, 3mbps down)

cgn2-rog router/modem

1 laptop (vista)

previous net: fibe 12 bell dsl (yes that's right).

 

technician came to install my new rogers internet.  he did his tasks and everything was good.  tested with his own laptop and made sure my laptop was able to connect to the internet both wireless and wired.  before he left he suggested to do the speedtest to see how fast rogers internet is (since i asked about the actual speed advertised).

 

issue:

- connection dies during speed test.  dies not drops as in pc or router has to be restarted in order to get connection back (100% true on wired connection.  wireless gets the connection back some times).  diagnose and repair does not do anything.

- normal use such as browsing, email, etc the connection stays and same performance as bell based on observation during normal use.

- bell internet is still active but will be disconnected in a day or so.

 

speed test:

1) ping test - normal

2) download test - spikes up to super speed then gradually slows down and continues to decrease until connection dies.  network becomes unidentified network and no connection to internet is being reported.

3) upload test - usually never reached on wired connection.  it sometimes comes back on wireless.

 

wireless speed test:

average 3mbps down, 3mbps up.

 

the issue has been reported to rogers.  tech rep confirmed that she doesn't see any issues on rogers side.  did the usual modem reboot, clearing interference etc and nothing.  a technician is scheduled to come to investigate the line.  note that the first tech confirmed everything was ok when he came to install the router.

 

i know my laptop is capable of higher internet speeds and from my bell internet, my speed hovers between 10-12ish mbps download (speed test).  i've connected my laptop to my friends connection and have had 23-25 mbps down (speedtest on internet express), and over 50 something on others (teksavvy, and my work network not sure of provider but if i remember correctly we have minimum t1 speed).

 

anyone else experienced this before and (hopefully) got it resolved?  the deal is good pricewise, but the advertised speed is not realized on actual use.  my bell fibe 12 (12mbps down) is 2.5 times faster if comparing it right now with my supposed rogers extereme internet (35mbps down).  though a little cheaper Smiley Happy

 

anyhow, any input, advise?!  thanks in advance.

 

 

***edited labels***

Resident Expert
Resident Expert
Posts: 13,829

Re: Internet drops when doing speed test! (internet extreme 45$ deal) - toronto

Hmm, never seen the speed test do that.
Seen it fail before the upload, seen it poor results... But not drop the connection.

I DOUBT this is it, but have you tried updating the the drivers on the network card? Some wired intel and Realtek ones have had some issues recently, seemingly with larger packets, which might happen on a speed test.


I've Been Here Awhile
Posts: 4

Re: Internet drops when doing speed test! (internet extreme 45$ deal) - toronto

thanks for the very quick reply.

 

i've never seen it before either.  i was able to borrow a laptop and do the test.  laptop was on win7 though.  anyhow, the issue didnt happen on the win7 laptop, but the speed was nowhere close to advertised speed.  at most, the fastest recorded download on speedtest.net was approx 21mbps as opposed to 35mbps that was advertised.  this was on wired connection.  wireless fluctuated a lot, but i didn't see anything over 20mbps on wireless.

 

i still can't rule out the laptop being the issue as i've connected my laptop on faster connection and there was no issue.

 

vista tells me that i have the most up to date driver for the nic.  but to be sure, i went to the nic site and surely enough there was a newer driver version.  i updated and unfortunately the issue persists.

 

nic: broadcom netlink gigabit ethernet

 

as you mentioned, it appears that the nic or something is choking on sudden large packets.  one thing i noticed that's different from the win7 laptop is that when the download test starts, the pointer needle on speedtest or the speed, doesn't spike up like on my laptop.  for example, on win 7, it spikes to 25 and then hovers at 25 then slowly decreases then hovers then goes back to 25mbps.  on my vista laptop, the moment the download test starts, the needle spikes almost to the red zone (like it was shocked), then it goes down quickly to about 20-30 range then slowly and gradually goes down until the connection dies.  i'm not sure if that was something to do with the issue, but that's the only thing i've noticed so far.

 

not sure what the rogers tech would do besides make sure there are no 'interference' on the line like what tech support said.  at least i want to see the advertised speed.

 

 

Resident Expert
Resident Expert
Posts: 13,829

Re: Internet drops when doing speed test! (internet extreme 45$ deal) - toronto

Yeah.. the one PC with it dieing.. may be something still on that PC..

I have seen it ocasionally.. between specific switches/routers and network cards.. that it is TRYING to link at say gigabit, but then fails/has those chokes.. force drop it to 100.. works fine.. but your chokiing your potential max speed then.. something in the way the two units talk/handshake

 

It does sound though in general.. that something may be up with your connection.. (regards to the speeds)
Mine with express (25/2) when you run it, will SPIKE to 40+ at the begining.. then drop down..and usually ends up between 25-29 for the download... takes a bit, but then the upload test runs, and i get the 2.