cancel
Showing results for 
Search instead for 
Did you mean: 

IgniteTV Surround Sound

DDave_ca
I've Been Here Awhile

Hello!  First post...

 

Long time Rogers customer, new Ignite subscriber.  Any Ignite customers having trouble getting surround sound (DDS5.1) to work from these Ignite TV boxes?  In the settings, I have tried both Auto and Expert (forced surround sound), but neither work.

 

My connection is not HDMI direct to my surround receiver - it only has optical (toslink/SPDIF) input.  My Panasonic TV has optical output.  I have DDS5.1 when using the smart TV for Netflix playback - not from the Rogers Netflix app.  I also tried using an audio extractor/splitter - same results.

 

Thoughts?

 

*** Edited Labels ***

135 REPLIES 135

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@Lott : As discussed extensively in this and other threads:

 

1. You need to set the audio output setting of the Ignite box to "Expert" and you should get properly encoded DD5.1 on any live or on-demand programming that you watch.  Assuming you're connected directly to an AVR from the Rogers Ignite box.

 

2. If you're going "through" a TV, then you'll need to properly set up the output audio from the TV's optical (or HDMI-ARC) signal to "DD5.1, or Raw or similar setting and not PCM.  I've provided previous links on that topic in this thread.

 

3. With any recorded programming, even if everything is set up properly, you will get a DD5.1 signal at the AVR, but the audio will come out the LF & RF speakers only because that's currently what's happening on recorded material with Rogers Ignite. At some point in the future, this should get fixed.

 

4. Although it's possible to override the incoming incorrect signal from recordings using something like "5/7CH Stereo" in the AVR, you will not experience the audio as originally intended.

 

5. Most of what I've stated above relates to HD channels, the majority of which provide properly encoded DD5.1 signals.  For SD channels and some HD channels, the audio signals are DD2.0 and can be decoded by DPLII in the AVR to provide surround sound.  Some HD channels are such outliers - Global is currently DD2.0, as is CTV2 and CP24. CBC (and some PBS) can be "improperly encoded" DD5.1 when the original programme is not DD5.1.



Re: IgniteTV Surround Sound

Lott
I'm Here A Lot
Thanks for the response @57. My TV is a bit old and does not have an HDMI-ARC port for my SONOS sound bar. So I used the SONOS-supplied optical output to HDMI converter, connected to SONOS. Then I have the ignite box, PlayStation, and blue ray disc player connected to my TV via its Input HDMI ports. Only the ignite box seems to have a problem playing sound through Sonos. I will try your suggestions above again I a while, but I swear I tried the expert setting in the ignite and still didn’t work.

I am not very well versed in this audio tech lingo, but I hope I explained it well enough. I have a sharp aquos TV that also seems to assume a tech savvy user. 😬

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@Lott wrote:
I used the SONOS-supplied optical output to HDMI converter, connected to SONOS. explained it well enough.  😬

Not sure why you're using this at all. If all of the devices are connected to the TV via HDMI, why not simply connect the TV's audio output optical port (properly configured for "external" speakers and DD or Raw) to the Sonos?



Re: IgniteTV Surround Sound

Lott
I'm Here A Lot
That’s exactly what I did, but for some reason the sound is not coming out of Sonos for ignite but the others (disc player and PlayStation) are. 😩

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@Lott : Here are a couple of things to try/experiment with.

 

1. Try feeding the Ignite HDMI cable to a different input on the TV - one you know works for the other devices.

 

2. Try setting the Audio output format on the Ignite box to "other/PMC" if there is such an option.

 

3. Try swapping the HDMI cables. There may be an issue with the one you're trying for ignite - again, use a cable that you know works for other devices?

 

Good Luck.



Re: IgniteTV Surround Sound

Lott
I'm Here A Lot
Hi @57! Firstly, thanks so much for taking the time to help me with this problem. I haven’t been exact with my set up so really sorry! Right now, I have one HDMI input cable from tv connected to an HDMI switch box that is connected to my three sources (ignite, PS and disc player). So I am pretty sure it has not to do with the cables. Before I ended up with this set up, I have tried what you described, switching cables directly to each and every one of my devices. It is only the ignite box that doesn’t work.

In the #2 suggestion, I went to the Rogers settings, then device settings menu, then Audio, then HDMI audio output and selected STEREO (other options were auto detect and expert mode). Is this what you meant? This is what I did, and no success.

I am starting to think this issue is something specific to how ignite passes through sound to tv and a setting that I can’t seem to figure out, not my connection set up.

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@Lott : I'm not sure if you've tried this yet, but try connecting the Ignite box directly to the TV without going through the HDMI switch.  If that doesn't work, I'm probably out of ideas.



Re: IgniteTV Surround Sound

Square
I'm a Reliable Contributor

For cripps sake, when is this problem going to be fixed???!!  Soon will be 2 months, rogers stated it will be fixed shortly, ha ha.  Now programs recorded on Global have no surround sound and now the sound has an echo and sounds like garbage!  Why o why did I switch to Ignite?

Re: IgniteTV Surround Sound

WJ-McKay
I've Been Here Awhile

Ignite TV W/Yamaha Sound Bar

 

The last two weeks have been a serious pain in the backside.  

My Ignite TV box no longer signals through my YAS207 sound bar to my TV so in order to watch TV I need to keep swapping cables and connect it directly to my TV.  

Every other device is working correctly passing through my sound bar (HDMI) and to the TV - BOTH of my ignite TV boxes have stopped working properly.  Once it goes into sleep mode, or when booting and comes off the 'Welcome/bienvenue' etc screen, it craps out and the TV stays blank. 

Is it the constant updates to the Ignite box?  I think I may get rid of it and go back to the old cable boxes.  I don't want to go back and forth to the store swapping boxes for no reason.  

Like I said all my other devices work properly.  Android, apple, playstation, chromecast etc...

Re: IgniteTV Surround Sound

Hello, @WJ-McKay

 

Welcome to the Rogers Community Forums!

 

I can see how frustrating this ordeal has been for you, you definitely should not have to be swapping cables all the time for your TV service to work.

 

It sounds like there is an HDMI handshake issue happening. Please go into the Settings on the Ignite TV box. Scroll down to Device Settings and then Power Preferences. If the Power Saver is turned On, please turn it Off. 

 

Do you see any other options available in the Power Preferences? Please post a screenshot of the Power Preferences settings so we can ensure everything is set up properly.

 

We look forward to your response.

 

RogersTony

Re: IgniteTV Surround Sound

WJ-McKay
I've Been Here Awhile

I did all those things already the only power save option was to change it to up to 5 hours that i was able to find.

So far

I will probably switch providers within the next two weeks if I can't get it working again.  After a year of no issues it's awful sudden.

Re: IgniteTV Surround Sound

Thanks for confirming that you have tried these steps.

 

Do you have an option called HDMI-CEC on the soundbar or the TV? If yes, please disable this option. Our RE's might be able to provide some additional steps that may help resolve this issue for you. I will tag them into this post: @-G-, @Gdkitty & @57.

 

Has anyone else in the Community experienced this type of issue when using a soundbar with Ignite TV? Please feel free to chime in with possible solutions you may have found.

 

RogersTony

Re: IgniteTV Surround Sound

No soundbar  here..
Do have a surround sound.

CEC is off on both, if I recall correctly.

Dont have any audio issues with the box.  It reboots fine without starting anything up, etc.
Works fine through passthrough on the surround sound, as well as doing surround.

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@WJ-McKay : Check out the following post which discusses the various issues that can go into things not operating as you want:

 

https://communityforums.rogers.com/t5/Ignite-TV/Problems-with-Ignite-Remote/m-p/456589#M5829



Re: IgniteTV Surround Sound

WJ-McKay
I've Been Here Awhile

I went through all my TV's options and can't find any CEC options for the HDMI.  

I'm trying to find a way to maybe disable the YAS-207's arc or cec or whatever it may have - would there be an option in the ignite box to shut it off so it stops switching video modes once it's up and running?  I get the welcome screen after it's booted for about 10 seconds then it blanks out right when the video attempts to switch over from that to the loading screen.

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@WJ-McKay :  A few comments:

 

1. I'm pretty sure all new HDTVs have an HDMI-CEC option somewhere.  It may not be called that, but it's there. Check out the link in my link about HDMI-CEC and what it's called in various TV brands, etc.  

 

2. ARC usually doesn't work without HDMI-CEC being "active" in the devices involved.

 

3. The Ignite box doesn't have an HDMI-CEC option that I know of.

 

4. There is a setting in the Ignite box for video output. If it's set to "auto" try changing it to 1080i as a test, and then eventually to whatever your TV will accept after a successful test.

 

5. Note that on some TVs not all HDMI inputs will accept all signals - only one HDMI port may be able to accept 4K for example...



Re: IgniteTV Surround Sound

Claire70
I Plan to Stick Around
I have a Sharp surround system that’s connected to my Sony tv by optical. Can’t get the remote to connect to it

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@Claire70 wrote:
I have a Sharp surround system that’s connected to my Sony tv by optical. Can’t get the remote to connect to it

Not quite sure what this means.  Please be aware that you need to go into the TV's audio menu and enable "external speakers" or something similar to send the audio to the surround sound system. The TV's internal speakers will then be turned off.  Also note that some TVs will not allow for this "passthrough" feature - rather it's meant only for the TV's internal tuner or apps like say YouTube, etc.  Here's an FAQ on the topic. See item 4:

 

https://www.digitalhome.ca/threads/faq-whats-available-in-dd5-1.17870/#post-135561



Re: IgniteTV Surround Sound

-G-
Resident Expert
Resident Expert

@Claire70 wrote:
I have a Sharp surround system that’s connected to my Sony tv by optical. Can’t get the remote to connect to it

Are you trying to find a setup code so that the Rogers remote can control your Sharp audio system?  If so, one of the following links should help you to find the code that you are looking for:

 

If you can't find a working code, I think that you can also search one for an audio system by entering setup code 992.  Press and hold "A + D" on the XR15 remote (or "Setup" on the older XR11 remote) until the status LED turns green, then enter code "9 9 2".  Next, press the "Channel Up" button until your sound system turns off, then press the OK/Select button on the remote to lock in the code.

Re: IgniteTV Surround Sound

Claire70
I Plan to Stick Around

I cannot connect my Sharp surround system to my ignite remote.  Two Rogers reps have spent an hour trying to do this to no avail.  I have to use my harmony remote to control sound.

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

Using the links in post 61, I entered "Sharp" under the audio code finder and found the following codes when I said I didn't know the model.  Have you tried entering the following codes when programming the remote for audio?   30186, 33736, 33097, 31942, 31956, 33929.

 

@-G- may need to advise how to enter the codes for your particular remote since I don't have IgniteTV.  Which model remote do you have - the 11 or 15?  Did you try the "scan" method outlined in post 61?  The scan method may take many button presses until you find the code that works since there are many codes programmed into the remote for many devices.

 

 



Topic Stats