cancel
Showing results for 
Search instead for 
Did you mean: 

Ignite stuck on Welcome screen

Koiraberg
I've Been Here Awhile
My ignite box has been stuck on the Welcome screen for nearly an hour now - every so often I will get a black screen, then the Welcome screen comes back again.
Internet is working and our other box in another room is working normally. Any tips would be most appreciated!
37 REPLIES 37

Re: Ignite stuck on Welcome screen

FH5
I'm Here A Lot
Yes.Exactly what mine did. I called them and they replaced it.

Re: Ignite stuck on Welcome screen

whocares5
I've Been Here Awhile

Yes, sounds exactly like mine, and you've done the exact things as I with no success. 

 

Call Rogers - experience suggests that box needs to be replaced.

Re: Ignite stuck on Welcome screen

LW3377
I've Been Around
What does that even mean????

Re: Ignite stuck on Welcome screen

-G-
Resident Expert
Resident Expert

@LW3377 wrote:
What does that even mean????

If you're asking about what the "Welcome screen" is, the Xi6 set-top box displays the following messages while it is starting up: 

 

Welcome.  Bienvenido.   Bienvenue.  

 

or

 

Welcome

Connecting to your entertainment experience

 

If the Xi6 gets stuck on one of these screens, it means that something is preventing it from starting up fully.  It might be due to a minor glitch (that can be cleared by power-cycling the device) or it could be caused by something more serious, such as a failed firmware update or defective hardware.

Re: Ignite stuck on Welcome screen

debbie1111
I've Been Here Awhile

This also worked for me.  Unplugged modem, plugged back in.  Unplugged Ignite Box, plugged back in.  Goodbye Welcome screen!! Welcome screen disappeared!!

Re: Ignite stuck on Welcome screen

rileymd
I've Been Here Awhile

Ignite TV stuck at start up screens

 

After some update from Roger end, it can't get past the new start up screen. Rebooted modem, rebooted the box, reseeded the remote batteries - stuck at new screens that are advertising things like voice remote tips, etc. Anyone else?

Re: Ignite stuck on Welcome screen

-G-
Resident Expert
Resident Expert

@rileymd  These Ignite TV tips are now shown on the Screen Saver.  If you see these, your set-top box should be up and running and have network connectivity.  Is it possible that your voice remote got unpaired somehow?  To check for this, press the Microphone button on the remote.  If the status indicator on the remote is red and you hear an error tone then your remote is not communicating with the set-top box.

 

Does your set-top box respond if your point your remote directly at it and press a button?  (e.g. the Select/OK button or the Microphone button)

 

If your set-top box is actually stuck on the Screen Saver and will not respond, that's a totally different problem... although there may be a few other ways that you can try to wake it up.

Re: Ignite stuck on Welcome screen

rileymd
I've Been Here Awhile
@-G-. Thanks. Yes, remote works. When I press rogers button, flashes blue. Makes the normal sound. Basically holding the remote directly in front, pressing guide, voice, holding power for 10 seconds - no response. Remote stlll works on tv.

What are some tricks to try to wake up the box? But my suspicion here is a failed firmware update.

Re: Ignite stuck on Welcome screen

-G-
Resident Expert
Resident Expert

@rileymd  A similar problem has happened before but usually it is a one-off glitch.

 

Try unplugging all cables (HDMI and Power) from the set-top box and leave them disconnected for one minute.  (While the STB is powered down, click the Microphone button on the remote again to confirm that it is not communicating with anything.)

 

Next, reconnect the HDMI cable and then connect the power cable.  Hopefully, this will reset things back into a good state.

 

 

Re: Ignite stuck on Welcome screen

rileymd
I've Been Here Awhile
Progress! Your suggestion helped.
I unplugged for few minutes, and when I press the Mic, it still seems to be working. Then I figured out that my kids mixed up the remotes, so this remote is the basement. BUT: when I went to switch them back, I found out that I have 2 remotes now paired to the basement STB (because yesterday I paired the living room remote to basement! ). So, how do I re pair the original remote back to the living room TV STB? Thanks so much!

Re: Ignite stuck on Welcome screen

rileymd
I've Been Here Awhile
Googled it and it's been re - paired! So summary: no issue from Roger's end. Total user issue (I blame the kids). Thanks so much, love this forum. Thanks @-G-

Re: Ignite stuck on Welcome screen

-G-
Resident Expert
Resident Expert

@rileymd wrote:
So, how do I re pair the original remote back to the living room TV STB? Thanks so much!

That depends on which remote you have.  First, you'll need to un-pair the remote:

 

If you have the older, contoured XR11 remote, press the "Setup" button on the lower left until the status LED turns green, then key in code "9 8 7"

 

If you have the new XR15 remote, press and hold the A and D buttons simultaneously until the status LED turns green, then key in code "9 8 7"

 

Next you will need to re-pair the remote.  Point the remote directly at the set-top box and press the Microphone button.  You should now see on-screen prompts with step-by-step instructions on how to to complete the pairing.

 

If you should run into any problems getting the remote paired, you can find a slightly more complicated official procedure here: https://www.rogers.com/customer/support/article/pairing-the-voice-remote

Re: Ignite stuck on Welcome screen

Saskey
I Plan to Stick Around

Ignite Reboots to "Welcome. Bienvenido. Bienvenue"

 

Ihave had Ignite for less than two weeks, but it has an infrequent and irregular habit of "rebooting" or something.  The screen goes black, then comes back with just the above message in the centre of the screen. Then goes black again, then the message, and this repeated four times yesterday, followed by "Welcome [to entertainment...]" or similar message and then the program returns, except for Netflex, where it returned to TV and not Netflix.  The previous time this happened, as I recall, the message appeared only once before returning. I had thought initially that it was some sort of update, but there was no indication of this, and four times seems excessive (well, one time is excessive). Is this a common issue and is there a known cause?

[EDIT: To be clear, my Ignite is NOT stuck on the Welcome screen! It just occasionally and randomly brings up the screen and then returns to TV, so NOT STUCK on welcome screen.]

 

Re: Ignite stuck on Welcome screen

Hello, @Saskey

 

I can understand how annoying it is to experience this issue. It sounds like there could be an issue with the Ignite TV box or the WiFi connection.

 

  • How many bars on WiFi do you have on the Ignite TV box? 
  • Do you have more than one TV? If yes, have you noticed the same issue on another one of your TVs?

 

If you have not already please reboot the Ignite TV modem, once it has come back online reboot the Ignite TV box that is experiencing the issue. Let us know if it is happening again and please document the time it happened so we can see if there is any errors logged on our end.

 

We look forward to your response.

 

RogersTony

Re: Ignite stuck on Welcome screen

Don_Ca
I'm a Reliable Contributor
Sounds like a defective box to me. It should not be rebooting like that.

If this is the post you commented about elsewhere, I agree, this should NOT have been merged into this thread.

Re: Ignite stuck on Welcome screen

Saskey
I Plan to Stick Around

RogersTony - Thanks for the reply.  I just logged in and read your comments a few minutes ago, however, just a short while ago (about 5:55 PM) , the screen blanked, followed by the Welcome message, and this repeated about 4 or 5 times until it returned to TV. Then just a few minutes later, it repeated the sequence, then a few minutes later did it again. Sometimes after the first blackout, a menu appears, but flashes by so quickly it is difficult to see it. So, after this happening, I did reboot the modem and TV box (unplugged both, then connected the modem then the TVbox), but will need to wait to see how that goes, as it has only done this less than once per day, so not continuous.

We have only one TV; I do not understand your first question - what bars on the Ignite box?

I will let you know if this persists after the reboots.

Re: Ignite stuck on Welcome screen

-G-
Resident Expert
Resident Expert

@Saskey wrote:

RogersTony - Thanks for the reply.

 

We have only one TV; I do not understand your first question - what bars on the Ignite box?

I will let you know if this persists after the reboots.


I believe that @RogersTony  was asking about the WiFi signal strength that your set-top box was seeing.  If you press the i (Info) button while watching TV, you will see signal strength bars next to the current time/temperature.

You can also check the WiFi signal strength by going to Settings / Device Settings / Network.  Ideally, it should say that your WiFi signal strength is either good or excellent.  If it is weak or poor, then that could account for some of the problems that you are seeing.

We Want Your Opinion
Would you be interested in becoming a Community Testing Lab member?
Topic Stats