cancel
Showing results for 
Search instead for 
Did you mean: 

I have bought a sim activated it online and it's still not registering (iPhone 4s)

Bjparise
I've Been Here Awhile

Hey I have just purchased a new pay as you go sim and went through the gears of activating it online and it said that its activating in my phone and would take an hour but its been about 3 now and it's still not going it just says no service on the top left. Just wondering if anyone knows what's up or if someone else is having this problem or had it and fixed thanks guys

 

****Edited Labels****

1 ACCEPTED SOLUTION

Accepted Solutions

Re: I have bought a sim activated it online and it's still not registering (iPhone 4s)

Meowmix
I'm a Trusted Advisor
Hello Bjparise

Have you tried turning off the phone and turning it back on?. Also have you tried contacting Rogers PayGo reps to see what's going on?

View solution in original post

4 REPLIES 4

Re: I have bought a sim activated it online and it's still not registering (iPhone 4s)

Meowmix
I'm a Trusted Advisor
Hello Bjparise

Have you tried turning off the phone and turning it back on?. Also have you tried contacting Rogers PayGo reps to see what's going on?

Re: I have bought a sim activated it online and it's still not registering (iPhone 4s)

Bjparise
I've Been Here Awhile
Got it working thanks. Know anything about finding the 4 digit passcode?

Re: I have bought a sim activated it online and it's still not registering (iPhone 4s)

Ejoremi
I've Been Around
Hi Meowmix,

Thanks for sharing this. I just changed my SIM card number online for an IPhone 6, then turned the phone off, then back on and it worked.

Re: I have bought a sim activated it online and it's still not registering (iPhone 4s)

Meowmix
I'm a Trusted Advisor
Hello @Ejoremi

That is great to hear! You are welcome 🙂
Community Testing Lab

We’ve got an amazing opportunity to test our upcoming Gateway!

Click here to find out more!

Topic Stats
  • 4 replies
  • 2028 views
  • 2 Likes
  • 3 in conversation