Hitron Router/Modem, ethernet doesn't work

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Here Awhile
Posts: 2

Hitron Router/Modem, ethernet doesn't work

There is on computer on Win 7 that woks with this router and another on Win 8 that doesn't. The Win 8 computer (my laptop) will only connect wirelessly and even using the same cable that the Win 7 computer is using won't fix the issue.

 

What I really want to do is plug a switch into the cable that runs upstairs to provide wired internet to all of the devices up there, hoever this has proven to be quite troublesome as taking the cable from the Win 7 computer and plugging it into the switch then running a cable back into the Win 7 computer only gives a limited acess warning and no valid internet conection.

 

Please help quickly as this modem/router combo has proven to be an extreme pain the . and many hours of pure frustration have already been spent on this issue.

 

 

***edited labels***

Solved! Go to Solution.
Resident Expert
Resident Expert
Posts: 13,996

Re: Hitron Router/Modem, ethernet doesn't work

How long ago did you get the modem?

There is a firmware update which usually should push out within 3 days of getting it.. this can fix SOME of the issues.

 

Question... what type of wired network card does the win8 laptop have? 10/100 or 10/100/1000?

And same goes for the switch.. is it a 10/100 switch or a 10/100/1000 switch?

Currently, it appears that the Hitron has some issues with auto negotiating with some 10/100 devices (end devices or things like switches, etc).

 

Conneccting a gigabit switch into it, should work ok.. then if you connect a 10/100 device into that, since the 10/100 is negotiating with the switch.

I have multiple 10/100 devices conneted into 2 gigabit switches here, and havent had an issue.



I've Been Here Awhile
Posts: 2

Re: Hitron Router/Modem, ethernet doesn't work

The modem was bought a few months back and I doubt anyone in my family has taken the time to update the firmware if it is a manual thing. I'm not sure what you meant by push out.

 

The laptop, as well as the switch, has a Gigabit card, and this is why it's confusing me.

 

I've noticed multiple people having problems with this hitron thing and to be honest it's driving me nuts.

 

Thank you for your time.

 

Resident Expert
Resident Expert
Posts: 13,996

Re: Hitron Router/Modem, ethernet doesn't work

Firmware should be pushed out automatically from rogers end.

you can log into the unit, and find out what SW version is shows on the first page which comes up.  It should be at 4.3.4.2

SHOULD be by this point.. but good to check, just in case.

 

Yeah, thats really odd, if they are both Gigabit. 
Specially if you have tried the same cable that works on the 7 machine, and then it doesnt work on the 8... its not like the cable just isnt capable.

 

(the one running to your upstairs, etc.. might be another story?)

Double check the cables, that they list at CAT5e or CAT6

 

ONLY wired issues i have seen come up from it, are 10/100 related..


EG: currently, i have the CGN3.. with the Rogers security router, into port 1 (which is a 10/100 netgear, and seems to work).
Port 2, goes up to my ASUS RT-N66U router, set as a wireless access point (which is 10/100/1000).  (which has my bluray, and surroundsound into it)
Port 3, goes to an 8 port dlink switch, 10/100/100, with a PC and Ext hard drive connected 10/100/1000 and a wireless printer connected 10/100

Port 4, goes to a 5 port 10/100/1000 asus switch, with my media PC, and a xbox 360 into it.
Everything seems to link fine.

 



I've Been Around
Posts: 1

Re: Hitron Router/Modem, ethernet doesn't work

Do you know if there has been any resolution to this issue since your last posting.

 

I ordered this new service at the end of May and until now, no one seems to have an answer for me. Anything 10/100 gets a max of about 35Mbps download.

 

Any help would be appreciated.

Highlighted
Resident Expert
Resident Expert
Posts: 6,229

Re: Hitron Router/Modem, ethernet doesn't work

This is a well-known issue, at least here within the forum.  You are running into a firmware bug in the CGN3 which throttles the download rates for directly connected devices where those devices are 10/100 Mb/s only.  You can confirm this by looking at the back of the CGN3 to determine what colour the port LED indicates.  If its yellow/orange, the interconnect rate with the device is 1 Gb/s and you should not have any issues with throttled download rates.  If the LED is green, the interconnect rate is 10/100 Mb/s and you will end up with throttled download rates.  That can be the result of either the device port that is connected or/and the ethernet cable that is used, as is might not support higher data rates as well.

 

The solution, until a bug fix is issued is to use a gigabit port equipped router, firewall, or switch between the CGN3 and the devices which are 10/100 Mb/s equipped.  If you take a read through some of the recent threads, you will see this is a definite issue at this time.

 

The firmware bug is present in both Gateway and Bridge mode.  As well, the front LED which indicates the connection rate, 10/100 Mb/s or Gb/s always indicates 10/100 Mb/s, yet another firmware bug to be resolved.



Order Now!
Wilder vs. Ortiz II Live
LIVE: Saturday, November 23, 2019 8PM ET
Channels: 348 (HD) | 350 (SD) | Ignite TV 499
Price: $74.99 (HD) | $69.99 (SD) | Ignite TV $74.99
DTV can order on Nov. 21st & Ignite TV customers can order now!

Reigning heavyweight world champion Deontay "The Bronze Bomber'' Wilder takes on his most dangerous challenger as he defends his WBC title in a rematch against once-beaten Cuban slugger Luis "King Kong'' Ortiz.

Topic Stats
  • 5 replies
  • 6006 views
  • 1 Like
  • 4 in conversation