Hitron Modem won't allow browsing

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
Showing results for 
Search instead for 
Did you mean: 
I've Been Here Awhile
Posts: 2

Hitron Modem won't allow browsing

I recently upgraded to  the Hitron Modem and now one of our main desktop won't allow browsing...will not connect.  I connect through wifi and have an IP address and I pinged google with no problem.  Tried IE9  and Chrome, no luck.  the Apple devives and another desktop are working fine.   Guessing its some sort of gateway/DNS issue.  Any suggestions welcome



***edited labels***

Solved! Go to Solution.
Resident Expert
Resident Expert
Posts: 6,345

Re: Hitron Modem won't allow browsing

Here is your original thread.  It was moved from the General community thread:




I suspect you might have a DHCP issue as Wayner92 suggested.  The pc or laptop should pick up an IP address and DNS server address automatically unless they are selected for manual entry in the TCP/IP settings for the ethernet or wifi adapter.  Navigate to Control Panel.....Network and Sharing Center........Change Adapter Settings.  On the ethernet or wifi adapter, ......Right click on the ethernet or wifi adapter and select Properties.  On the Ethernet Properties for example, scroll down to the Internet Protocal Version 4 (TCP/IPv4), select and then select the properties for that choice.  The Properties window that pops up should show:


1.  Obtain an IP address Automatically

2.  Obtain DNS server address automatically


With those selections, the pc or laptop should obtain its IP and DNS address from the CGN3 automatically.  Should they need changing to auto mode, I believe you will have to reboot the computer.