Hiton CGN3 problem with Cisco Switch

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I Plan to Stick Around
Posts: 27

Hiton CGN3 problem with Cisco Switch

I installed a "new" Hiton CGN3 Cable meodem a few days ago.

Other than a few self inflicted problems, I have not been able to get my Cisco  switch (10/100/1000) to work with the CGN3. I wokrd great with my Linksys 54G with the old cable modem in BRIDGE mode.

I have not checke the firmware to see if its at 4.2.4.3 (I'm not at home right now).Ill do that tonight.

 

Q. Does the CGN3 support Auto MDI-x

 

When I plug the switch into the modem, all the port light flashh rapidly...for a long time .. including the lights on the modem..

 

All hardwired devices work fine off the CGN3 as does both wifi protocols.

 

I am contemplating picking up a switched 10Base T cable to see if that is the problem (if I can find one)

 

I have not found any reference to Auto MDI-X in the user manual.

 

I will hunt for in-depth specs on the CGN3

 

Any ideas would be appreciated. 

 

 

***edited labels***

 

Regards
Solved! Go to Solution.
Resident Expert
Resident Expert
Posts: 13,978

Re: Hiton CGN3 problem with Cisco Switch

As far as i know.. it would be auto MDI-x... most devices are now.
Though, i havent tested in a case where i had an incorect cable, etc..

 

Right now, i currently have a Dlink 8 port, an ASUS 5 port, and a Asus router acting as an AP into the CGN3, and all of them are working fine.



I Plan to Stick Around
Posts: 27

Re: Hiton CGN3 problem with Cisco Switch

Thank you for the quick response.
I'll pick up a crossover cat 5 cable and try it this evening to see if it's a fix, no Auro MDI, or the same. I will advise.
Regards
Regards
Resident Expert
Resident Expert
Posts: 13,978

Re: Hiton CGN3 problem with Cisco Switch

SHOULDNT need a crossover though.
Mine are all just regular patch cables between the CGN3 and the switches.



I Plan to Stick Around
Posts: 27

Re: Hiton CGN3 problem with Cisco Switch

Thank you.
You are correct, no crossover needed.
Removed cables one at a time from switch and found one causing the issue.
Left cable out and things are normal.
Fyi firmware 4.2.4.5
Now to find the issue with the cable.
Thanks again for the prompt response.
Regards
Regards
Resident Expert
Resident Expert
Posts: 13,978

Re: Hiton CGN3 problem with Cisco Switch

No prob 🙂

Glad you found it. 
somtimes thats the best course.. go one by one, process of elimination.