HTC ONE LTE indicator ? or no indicator?

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I Plan to Stick Around
Posts: 24

HTC ONE LTE indicator ? or no indicator?

I have never seen an indication that I am connected to the LTE network.

I have an LTE sim.

My data package says LTE.

The network settings say GSM/HSPA/LTE auto.

MY phone says 4G with max speed tesed at like 5M down.

Is this it for Roger network here in Ottawa? Or? Do I jave a problem with this handset?

 

Hoping for some insight,

 

ggparts

 

***edited labels***

Solved! Go to Solution.
I'm a Trusted Advisor
Posts: 32,019

Re: HTC ONE LTE indicator ? or no indicator?

Hello ggparts

Have you tried doing a factory rest to make sure if that will fix the problem?. If so and u still have this issue, have u gone to A Rogers store or called Rogers so they can see maybe something on the account or area u live in may have a issue?


If u have tried all this, then ask them to send in the phone for repair. It could be the LTE chip causing the issue.
I Plan to Stick Around
Posts: 24

Re: HTC ONE LTE indicator ? or no indicator?

I did the full (hard) reset and now, I do see the LTE indicator for the first time since I got the phone. I must, however make the comment that a Rogers online tech was so adamant the the HTC ONE will never show LTE that 4G is the same, that he provided support number for HTC and I called them and they also indicated there would be no LTE icon.
I'm a Senior Contributor
Posts: 267

Re: HTC ONE LTE indicator ? or no indicator?

Strange, though in the US the phones down there don't say LTE, but 4G or maybe 4G LTE instead. Different marketing spin here vs there, surprised the Rogers tech was spewing misinformation like that, as did the HTC rep apparently.

I'm a Trusted Advisor
Posts: 32,019

Re: HTC ONE LTE indicator ? or no indicator?

Hello ggparts

The tech support agent & the HTC agent are not correct. The US & Canadian model will show " LTE" indicator. I guess both reps are not aware of anything & just give out the wrong info once again.