cancel
Showing results for 
Search instead for 
Did you mean: 

Global App Authentication not working

heather7218
I've Been Around

Week of Nov. 30th my Global App and a few others stopped working.  I would try to sign in to the Global App using my sign on and correct password.  It would start to Authenticate and then shutdown telling me to call Rogers.  I tried that but every time I call it's an hour to two hour wait.  I have turned off my iPad and restarted it, I also deleted the app and reinstalled it.   This is only happening with Global.  I've contacted them and they stated I should check with Rogers re: their authenticating system but I can't get a hold of them.  Anyone else having this issue???

8 REPLIES 8

Re: Global App Authentication not working

RogersZia
Moderator
Moderator

Good evening and welcome to the Rogers Community Forums @heather7218!

 

The GO apps are a convenient way to catch up on the shows on your own time. I appreciate the details you've provided. Sounds like we may have to refresh the permission for this app for you. Please reach out to us via PM @CommunityHelps so we can assist you further.  To learn more about how to PM, please see this post

 

 

 

 

RogersZia

Re: Global App Authentication not working

I have a similar problem. The roku app lets me authenticate, but I only have access to Global News and Global TV.
It keeps telling me that I'm not subscribed through my provider, but I do have the channels available with my subscription.
What's going on?

Re: Global App Authentication not working

Hi @dtsaudio,

 

Welcome to the Community!

 

You've come to the right place. We'd love to help you out here. In order to best assist you I do have a couple of questions:

 

1) Do you have access to view content on the Global app?

2) Are you unable to access other GO apps (e.g. TSN, CTV, Citytv Video) via Roku?

3) Is there a specific app/show you're getting the error on?

 

Looking forward to hearing from you :).

 

 

 

RogersZia

Re: Global App Authentication not working

I can only access Global TV and Global News. I cannot access any of the other stations supposedly available. That's History, Food, and a bunch of others.
The CTV app does not work at all. Haven't tried City TV.
TSN Go doesn't work.
It's as if Bell is blocking all other providers access.
All the mentioned stations, I have TV subscriptions for. They are all part of my package.

Re: Global App Authentication not working

Hello, @dtsaudio.

 

Thank you for providing us with the additional info; are you accessing all these apps on Roku? Have you tried these apps on a computer/laptop?

 

We can further investigate it and submit a ticket if required. Please send us a private message at @CommunityHelps. You can find details about our private messaging in this blog

 

Cheers,

RogersMoin

Re: Global App Authentication not working

I have tried all the apps on Roku, my Samsung tablet and my Android phone.
I can't even log in using the phone and tablet.


Re: Global App Authentication not working

janisr
I've Been Here Awhile

Hi...for some reason, when I try to use my Roger's credentials to authenticate within the GlobalTV app, it tells me I'm not authorized and to call Roger's.


CityTV and CTV apps all work fine.
The apps are on my Android phone, and I have cleared cache and tried again, to no avail.
Any ideas what the issue might be? I recently switched to Ignite TV, perhaps there's some issue there? I DO have Global in my channel lineup.

Re: Global App Authentication not working

Greetings @janisr!

 

My name is Corey and I'm here today to help address this Global app authentication issue. 

 

In this case, I'd like to try refreshing your account permissions as the first step but I'll need to gather your account information in private in order for us to do this.

 

Please send us a private message to @CommunityHelps so we can assist you further. For more information on how our Private Messaging system works, you can find out more here.

 

Regards,

RogersCorey

We Want Your Opinion
Would you be interested in becoming a Community Testing Lab member?
Topic Stats
  • 8 replies
  • 2083 views
  • 0 Likes
  • 6 in conversation