Galaxy network icons not showing? Is there a setting?

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I'm a Trusted Enthusiast
Posts: 143

Galaxy network icons not showing? Is there a setting?

As the title says , have SGH-T589R and din;t see any network icons. The 3G or 2G icons don't show. Wondering if I screwed up some settings somewhere.

Couldn't even see teh 3G icon when I drove close to the tower (had visiual line of sight to it..maybe 100 yds).


***edited labels***

 

 

 

 

I'm a Senior Contributor
Posts: 267

Re: Galaxy network icons not showing? Is there a setting?

Is this the Rogers version of the Galaxy Q or another carrier?

Sounds like you don't actually have data on the device working.

That would likely mean the wrong APNs if it's not a Rogers phone.

I'm a Trusted Enthusiast
Posts: 143

Re: Galaxy network icons not showing? Is there a setting?

It's a Rogers phone. Apparently the 3G network is down here right now as they upgrade the towers to LTE , but ALL of it ..for a week??

 

I'm a Trusted Advisor
Posts: 32,019

Re: Galaxy network icons not showing? Is there a setting?

Hello BeerHunter125

Have you called Rogers or know someone with a Rogers wireless phone to see if theirs is doing the same? If not then it may be your plan or phone. I really doubt they would shut off the data just to upgrade the towers to LTE.

 

 

EDIT - i just read what you wrote on the other thread. Are you sure the store is correct when they say the data is shut off & all just to upgrade the towers to LTE? That makes no sense at all if it takes 1 whole week to be off.. I can understand a few hours or a day but NOT a week.