cancel
Showing results for 
Search instead for 
Did you mean: 

Error 0X80070057 When transferring files to the internal SD card on 2.2 Captivate

plaincorgi
I'm Here A Lot

I upgraded my Captivate to 2.2 using the instructions that rogers provided. Before I did so I copied all my music off of the device.

I then upgraded the phone and then did a factory reset to 2.2 stock, as well as wiping the cache and all user data. I have done this twice now and get the same issue both times.

 

When I plug my phone into a computer it asks what mode I would like to use. I choose Mass Storage as keis is not installed on the computers I am using. I can start copying my music onto the phone, but when I get to around 1.3GB in, it just stops and throws the below error:

 

An unexpected error is preventing the operation. Make note of this error code, which might be useful if you get additional help to resolve this problem:

 

Error 0x80070057: The parameter is incorrect.

 

At this point I am unable to copy anything to the internal sd card, nor can I even make a new folder. Unmounting/remounting the phone has no effect. I have reset the phone/deleted user data/reset cache three times now and still I cannot copy all my data to the phone.

 

***edited labels***

 

38 REPLIES 38

Re: Error 0X80070057 When transferring files to the internal SD card on 2.2 Captivate

The telephone they sent me is a 2.1 and I didn't updated it yet. So, nope, problem not solved. I do not have a 2.2 with a fully operatonal sd card.

Re: Error 0X80070057 When transferring files to the internal SD card on 2.2 Captivate

I received an email from samsung with a link toward the 2.2 update. I called rogers tech support to ask if there is a new update or they fixed the sd card back. Of course they were clieless the guy told me "I am not aware of any bug with thhis update". Anybody tried this update lately? It looks like the same version. I am refractary to upgrade again and end up with am unusable card again.

Re: Error 0X80070057 When transferring files to the internal SD card on 2.2 Captivate

Angry_Jeff
I've Been Here Awhile

I just called Rogers tech support about this issue. They are "escalating" the issue (ticket number C33738217)

Here's what I have found / tried (and doesn't work)
...
  • I tried formatting the Internal SD card using the phone menus....
  • I tried reverting the phone to Factory Default Settings using the phone menus...
  • I tried formatting the card using Windows
  • I tried Error Checking & Bad Sector Recovery....
  • I tried changing the card to from FAT32 to NTFS & re-formatting....
  • I tried changing the Virtual Memory on my Machine to various settings....
  • I tried all those steps above on both WinXP(32) and Win7(UltimateX64)....
  • I tried installing drivers from Kies > Tools > Install Driver
...None of these steps were successful. 
No matter what I do, Windows still recognizes the card as 2.20GB capacity and refuses to recognize any data afterwards, both in reading and in writing. If you look under Windows Disk Management, the drive is recognized as 2.20 GB (with a capacity of 13GB... interesting)
...
The worst part is this experiment: Try to fill your Internal SD Card with 2.2GB worth of data, then try to record a video with the phone. Then try to access that video using Explorer in Mass Storage mode. You will not be able to play / copy the file. It looks like the FAT isn't being read correctly by Win7/WinXP after there's more than 2.2GB worth of data on the Internal SD card. However, the phone itself is able to read the same data that Windows cannot, so it definitely looks like a Windows / Driver issue.
...
This issue doesn't seem to be a problem limited to this phone. That specific error message (0X80070057) seems to be an issue with external mass storage "flash drives" in general. It's possibly a bad driver associated with the Internal SD Card ? Not sure. I don't have a Mac, and I don't have Linux installed, so I can't say for those OSes. But I'm experiencing the same issue with both WinXP and Win7. My Win7 Ultimate x64 is 24 hours freshly installed. It's 100% updated with all the patches and there's barely any software installed. The issue happened before AND after Kies was installed. (Kies did not change anything)
...
It seems we are limited to 2 workarounds for now
1) Use the External SD card. It is recognized correctly within Windows.
2) Use Kies or Media Player (instead of Mass Storage). It is still possible to drag & drop within Explorer without converting. 
Obviously those are just workarounds. Not acceptable solutions... 
...
I talked to a Rogers techie who was very helpful and seems to be on the right track. He was going to escalate the issue using this ticket number : C33738217. I strongly suggest everyone who gets this problem to call Rogers. The more people who call, the more pressure goes to their escalation team.
...
I haven't tried reverting back to Firmware 2.1 (Not even sure if that's possible) Kies doesn't make it easy.
...
Has anyone tried to see if the same bahaviour happens under 2.1 ?

Re: Error 0X80070057 When transferring files to the internal SD card on 2.2 Captivate

If you revert it to 2.1 it will work to copy files beyond 2.2gb but it is such a hassle to revert it to the initial rogers stock version. 

Re: Error 0X80070057 When transferring files to the internal SD card on 2.2 Captivate

Angry_Jeff
I've Been Here Awhile

Called Rogers again. Their technician was supposed to escalate the ticket when I first called (2 weeks ago) but it's been sitting in no man's land since then. Plus apparently, the previous tech gave me an incorrect ticket number. I just called again, and another tech asked me for which version of Android I'm using and whether or not I tried removing the SD card... I almost started screaming.

PLEASE CALL ROGERS IF YOU ARE EXPERIENCING THIS PROBLEM. 

This is now my ticket number: C34490211.

They will ask all the same questions that are already documented here. Seriously, save yourself some trouble and tell those technicians how to get to this thread, otherwise they will make you turn in circle..

The only thing that prevents me from returning this phone is the fact that the external SD card works. Otherwise I would have returned it a long time ago.

...

Their technician confirmed there is no easy way of going back to 2.1, so we're all waiting on Rogers/Samsung to come up with a solution at this point