Data not receiving?

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
arice27
I've Been Around
Posts: 1

Data not receiving?

I have a Sony Ericsson Xperia Play, and my data has not been working for quite a while now.  I have tried everything suggested on every forum, with no success.  I have tried changing the APN multiple times and that has not worked either.

 

When I turn on data, the 3G logo will appear at the top.  However, only the sending arrow lights up, and never the receiving arrow.  Sometime, if I am lucky, the receiving arrow will light up for about 0.5 seconds when the data first connects, but that is it.

 

Any suggestions?

 

 

***Edited Labels.***

Meowmix
I'm a Trusted Advisor
Posts: 32,120

Re: Data not receiving?

Hello arice27


Have you tried doing a factory reset on the device to see if that will fix it?

If not have you tried contacting Rogers or Sony?