Connection problem with iPad

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Here Awhile
Posts: 4

Connection problem with iPad

brand new iPad & new Sim card

i go through the process of creating Rogers Account

I do have an account, a number, they got my money

but i can't connect

fortunately there is wifi at home and at work - no problem there

spent an hour with phone support 

they've passed it on to network ppl,

who will be in touch with me

 

it would be far easier to forget the fifteen bucks and go with Bell

 

before i do that:

has anyone encountered this problem?

how did you resolve it?

Thx

 

***edited labels***

Solved! Go to Solution.

Accepted Solutions
Highlighted
I've Been Here Awhile
Posts: 4

Re: Connection problem with iPad

djtrip, your tech support was better than mine, i guess

 

i was referred to "the Network people"

got an email, they were on it

but after a week, two weeks since Rogers took my money from visa

still no connection.

 

btw,

went to Apple store

guy put in a Fido card

it worked

isn't Fido=Rogers, but the cheaper version

 

guess it's problem with Rogers set-up/authentication process

i'm going to give them a few more days

View solution in original post


All Replies
Highlighted
I'm a Senior Advisor
Posts: 1,299

Re: Connection problem with iPad

Not sure how to fix this I had a similar issue but when I tried again it worked. But it they already got your $15 it's not worth trying again..

As for going with Bell activation is more annoying.. You have to do it through iTunes and you have to go through it each month where Rogers will renew itself if you set it up that way.
Highlighted
I Plan to Stick Around
Posts: 16

Re: Connection problem with iPad

I had a ton of issues setting up my iPad 3G with Rogers. Something might have gone wrong on their end, I know it did for me and it took them about a month to sort it out. It was about a week from my original phone call before data started work, I also had to replace the SIM card in between (at my cost). The bill is still incorrect every month because original they setup the iPad account with a 150MB (yes, MB) plan just so it would start working while they "sorted out the plan and billing issues".

 

Of course you might also want to verify that it's not the 3G network that's the issue as I'm not sure where your located. The network in downtown Vancouver has been a huge issue for about three months now on both my iPhone 4 or iPad 3G. Most of the time I can't even establish a connection to the 3G network and if I do it's super slow (0.30-0.80Mbps). Now I just pay them every month for data and use my iPad on WIFI, I would seriously recommend looking at one of the other carriers.

Highlighted
I've Been Here Awhile
Posts: 4

Re: Connection problem with iPad

I am not aware of any network connection issues with iPad.

As you already know, Rogers iPad plans can be activated directly on your iPad.

To Activate your iPad Plan follow the link from the Rogers website below:

http://www.rogers.com/web/content/ipad-dataplans?cm_mmc=Redirects-_-Consumer_Wireless_Eng-_-iPad_Pre...

 

 

Hope that helps!!

I am a Rogers employee, but my comments are my own and do not necessarily represent the views of Rogers or its affiliates. Je suis un(e) employé(e) de Rogers mais mes commentaires sont les miens et ne reflètent pas nécessairement le point de vue de Rogers ou d’une société de son groupe.
Highlighted
I've Been Here Awhile
Posts: 4

Re: Connection problem with iPad

Thanks for your assistance.

 

Unfortunately the problem persists.

 

I did register.

Rogers shows up as the carrier.

I've pretty well done what I can do on my end.

 

What shows up when i try to activate card is a box indicating:

"Restricted Network

Your selected cellular network is restricted. You can chose a different network in your settings."

the selected network is Rogers, and if i let it run it will do so forever

and not come up with a different network.

 

there was either a glitch (such as being put on some landline vs data network) in the startup process, or the sim is toast.

 

i've been an Internet customer of Rogers for as long as it's been around, and it makes sense to continue with them.

Also I've had issues with Bell; they're all the same.

It bugs me tho' that I could just slip in another sim and be done with it.

 

there should be some compensation

for having to go though this hassle simply because these companies

put out products that are still in alpha stage of development

 

i appreciate the opportunity to rant; thx again for the help

Highlighted
I've Been Here Awhile
Posts: 4

Re: Connection problem with iPad

just to update on the situation . . .

 

reset network settings again . . . (?fifth time) . . . no change

backed up and then restored original iPad content and settings . . . again . . .

(unfortunately installs only iOS 4.1.2, no 3.x, if that's the problem)

. . . no change

 

can't authenticate, cause the network i connect to is "restricted"

 

sent an email to some Rogers department yesterday

 

no response

Highlighted
I Plan to Stick Around
Posts: 16

Re: Connection problem with iPad

It sounds like the SIM might not be activated. You might have to call in, which unfortunately means spend at least 45min on hold. I had the same issue when I setup my iPad, saw the network but wouldn't connect. In the end I had to call tech support.

 

Good Luck!

Highlighted
I've Been Here Awhile
Posts: 4

Re: Connection problem with iPad

djtrip, your tech support was better than mine, i guess

 

i was referred to "the Network people"

got an email, they were on it

but after a week, two weeks since Rogers took my money from visa

still no connection.

 

btw,

went to Apple store

guy put in a Fido card

it worked

isn't Fido=Rogers, but the cheaper version

 

guess it's problem with Rogers set-up/authentication process

i'm going to give them a few more days

View solution in original post