cancel
Showing results for 
Search instead for 
Did you mean: 

Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

hamdan
I'm Here A Lot

I have Chromecast and it was working fine and I can send videos from my iPhone from YouTube and other applicable applications. Chomecast is not the only device I can cast videos on, my Samsung TV can cast as well. 

 

Now the icon disappeared from YouTube and other apps and I am not able to see the icon for both (Chromecast and TV). I tried to reset Chromecast, but the setup can not go through. Chromcast support suggested that I have to change a router setting, for example, AP Isolation is to be Disabled.

 

Note that I have't change anything I mean router or phone or app settings.

 

Thanks 

 

***edited labels***

 

96 REPLIES 96

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

ha123
I've Been Here Awhile

I also started to have the chromecast disappearance problem since a week ago.

Tried switching off 5GHz and rebooted, but Chromecast stopped working after 15-20 minutes. It is not the 5GHz setting change that makes chromecast temporarily reappear - it is rebooting the modem that brings it back for 15-20 minutes everytime one reboots modem.

 

Has anyone tried the DNP changes that NotSoTechnical posted yesterday?

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

User1685180
I've Been Here Awhile

I have 5 Chromecast Audio devices setup on my home network, on 5 difference audio devices, in 5 different rooms in the house ('Chromecast Audio' allows users to stream music to any speaker whereas 'Chromecast' streams video to TV's or monitors). My problem occured right after the patch update was sent to my routor to update the firmware. Previous to the update, my devices were working fine. I have the hitron cgn3acsmr. Here is what Rogers has tried. Diabling IGMP snooping setting, first on my 2.4G and then on my 5G. When that didn't work, we tried disabling the 5G wireless all together. In all scenarios, immediately after rebooting the modem, all my Chromecast diveces appeared on my network and worked fine. But, within 30 minutes, devices started disappearing and reappearing from my network and I get back to the original issue. What is interesting, is that the last Rogers Techspert rep said my IGMP was enabled, however, on 2 previous calls to Rogers, the setting was diabled twice. I connect through IOS devices. The apps I use to stream are Google Play Music. Hopefully this bit of info helps you guys troubleshoot the issue further. The only option that seems logical at this point is to change the router to Rogers's older router/modem that supports 2.4G only, that is, if you want to continue renting from Rogers. I have spent at least 24 hours (actual time) over the past couple of weeks troublshooting with Rogers, Rogers Techspert and Chromecast, on multiple phone calls.

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

There might be a couple of issues at work here, one is the current problem with Chromecast disconnects, and the second is a possible problem with google services due to the introduction of IPV6.  Ask for the trial firmware which will be V4.5.8.21, as seen in the first post in the following thread:

 

http://communityforums.rogers.com/t5/forums/forumtopicpage/board-id/Getting_connected/thread-id/3315...

 

When that is loaded, try your Chromecast devices with the 5 Ghz wifi network disabled and let us know if there is any difference.



Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

sdfasf
I Plan to Stick Around

I'm having the exact same issue with the chromecast and same router.  I'm not sure the beta firmware will work, as there is a thread in Rogers-Internet with people discussing this issue and they had mentioned the trial firmware didnt fix the issue

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Have you tried disabling the 5 Ghz wifi?  If not, can you try that and then try the Chromecast.  If that doesn't work, try a modem restart (pull the power and then power it up again), with the 5 Ghz already disabled and see if the Chromecast is available after the modem restart.  The conflict that I've seen is that in some cases there appears to a time for which the Chromecast will continue to work, and then become unavailable.  I've also seen a report indicating no problems after the 5 Ghz wifi was disabled.  So, its difficult to come to a solid conclusion at the present time.  There may be other variables involved but I haven't seen any common threads to help sort it out.  



Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

sdfasf
I Plan to Stick Around

I have tried with a reset. These are the things I've tried over the past week based on advice online (no success with any of these)

 

1. disabled 5ghz and rebooted (same issue, it connects for a short time and then disconnects)

2. set a static channel instead of auto channel and rebooted

3. set DNS to manual using OpenDNS figures and rebooted (the solution provided on the previous page)

4. changed wireless 2.4ghz from default g/n mixed to b/g/n mixed and rebooted

 

all of these solutions have not worked.  I am on firmware .20, so im not sure if .21 will fix the issue, but again, from what i've read, it doesnt fix the problem

 

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

I believe you're correct in that .21 has the same issue.  What are you using for the 2.4 Ghz network encryption settings?  Just curious.



Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

sdfasf
I Plan to Stick Around

Hi,

 

Encrypt mode = AES

Auth Mode = Auto (WPA/WPA2)

Security Mode = WPA-Personal

 

I never changed these, i believe these were default

 

would you happen to know if its possible to request the modem be rolled back to prior firmware version?

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Rolling back, I don't know if that would be entertained.  Usually moving forward is the preferred path, so I'm not sure what the response would be.  No doubt the engineering staff is working on this. 



Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Zaphod99
I Plan to Stick Around

Thought I'd report in after going through a trial firmware update. I'm running 4.5.8.21 and this problem is still not fixed. Goodbye, Rogers. Thanks for wasting my time. Just called Bell and they'll be here on Saturday morning to install my new internet. Finally going with a company that actually provides a serevice that works. First thing the guy on the phone said is, "Let me guess, Rogers firmware problem?" Haha....

 

Firmware update did nothing to solve this problem. Called Bell and making the switch on Saturday. I'm convinced this will never be fixed.

 

I feel your pain. I'm done with Rogers. I have wasted 11 years of my life as a customer of theirs and I've had it. Unaccpetable incompetence at evey level. When they screw up, they screw up big. Sadly, the only solution I have come up with is to switch to Bell. The technician will be here Saturday and I got a great deal.

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

sdfasf
I Plan to Stick Around

Hi, thanks for checking on the .21 firmware.  i've been considering a switch to another carrier as well.  II use the chromecast for so much, and the fact that the simple device doesnt work is really disappointing. I'll give it a month to see what happens, but i have a feeling this issue will not be resolved in a timely manner. Thanks for pointing out Bell, ill see what kind of deals theyre offering now

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

User1685180
I've Been Here Awhile

Now that user Zaphod99 has confirmed the firmware update 4.5.8.2 does not solve the problem, does anyone think that either A) purchasing a new router to use with a Rogers modem or C) replacing the current Hitron router with their older 2.4G-only capability would temporarily solve the issue?

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Zaphod99
I Plan to Stick Around

I'm curious to know if any confirmed Rogers staff members actually read or offer any solutions to these posts. We're all going around in circles here and there's no sign of a Rogers employee. We all have hundres of dollars worth of equipment that no longer works because of these firmware updates and we don't even get a single acknowlegment that this problem has been recognixed. I'm wondering if this is perhaps deliberate and, for some reason, Rogers don't want their customers using chromecast etc. Thoughts?

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Zaphod99
I Plan to Stick Around

The manual DNS solution does not work. Like everything else, it appears to work for about an hour and then the icon disappears once again.

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Here is the story that i got yesterday:

I reset my chromcast a half a dozen times and truly thought i had a faulty unit.

Exchanged it with no issues, and had the same problem with the new one

Got onto the online chat with a rogers tech..... he said the modem was working fine and if i wanted to fix the issue with chromcast a tech would be willing to try for 129.99 plus tax.

My answer was really? thats your solution?

He then told me that the issue was with chromcast, i should call them.... so i did

 

Chromcast advised that the update on the router made chromcast incompatble with this specific hitron modem and that they are in negotiations not just with Rogers but also with Hitron.

 

Right now there is no fix .... although i did not try the changes on the modem settings as of yet

 

After what i heard from chromcast i have a feeling it wont work for any length of times

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

ha123
I've Been Here Awhile

1: Has anyone tried a Factory Reset for Hitron modem? Does it help resolving the issue?

2: would switching to older 2.4G only modems be a solution to chromecast problem? How do we know Rogers also didn't  recently do the same mess up in other modems to block chromecast - not fixing this self-created problem  suits them as it saves them a lot of bandwidth !


@hamdan wrote:

I have Chromecast and it was working fine and I can send videos from my iPhone from YouTube and other applicable applications. Chomecast is not the only device I can cast videos on, my Samsung TV can cast as well. 

 

Now the icon disappeared from YouTube and other apps and I am not able to see the icon for both (Chromecast and TV). I tried to reset Chromecast, but the setup can not go through. Chromcast support suggested that I have to change a router setting, for example, AP Isolation is to be Disabled.

 

Note that I have't change anything I mean router or phone or app settings.

 

Thanks 

 

***edited labels***

 


 

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

breh
I'm Here A Lot

Chromecast no longer works on Hitron

 

I'm not sure what happened but it seems that the Chromecast no longer works properly. Rebooting the modem restores the Chromecast functionality temporarily but after about 30 mins it's gone again even though it's connected to the network.

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Zaphod99
I Plan to Stick Around

Ok...so there is a fix. It is 100% bad firmware. Don't let anyone tell you differenly. This is a problem caused by Rogers. The update to 4.8.5.20 killed all casting. I contacted Rogers on this forum (not technical support on the phone) and asked to be rolled back to the previous firmware (4.5.8.16). The problem was instantly fixed.  Thank goodness because I had already scheduled an appointment with Bell this past Saturday, and was fully prepared to change providers. This fix has kept me a Rogers customer...that is, until the next untested stupid update they try and force on me. 

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Just adding my data to this thread.

 

Note that this message contains an admission that the current firmware version (4.5.8.20) is known to have/cause problems with Chromecast.

 

Maybe a week ago, my devices stopped seeing my Chromecast (older generation).  Meaning to say, the apps did not have the casting icon (rectangle with wifi waves in the corner) any more.  All manner of Chromecast hard resets, unplugs, replugs, and router power cycling did nothing.  I even went and bought a current-gen Chromecast, thinking my old one got broken, possibly by a firmware update from Google.  But both devices exhibited the same problems.

 

However, as of right now, I have both devices working.  Here's my current setup and what I did:

 

  • Router/modem is a CGN3ACSMR
  • I have no idea what firmware version is running, because I can't find it in any of the router/modem admin pages.  Current firmware version is 4.5.8.20.  (Thanks, Datalink, for showing me where to find this.)
  • I have done power cycles of the router a few days ago, but when I eventually got it working, I didn't need to power cycle the router.
  • I did a hard reset of the old-gen Chromecast (hold the button for 25 seconds while it is powered)
  • Did many unplugs (power) and replugs of the Chromecasts during my fiddling
  • I already had my DNS servers manually set.
  • Residential Gateway Function is Enabled
  • UPNP is Enabled
  • I had to temporarily disable 5G before the Chromecasts could be found using chromecast.com/setup
  • I was able to reenable 5G after the Chromecasts were set up
  • I did my set up using a screen/TV that was extremely close (less than a foot) from the router (my thinking being that this maximizes the chances of it connecting to my router instead of any neighbours, etc.)
  • chromecast.com/setup did not work from any desktop or laptop computer.  I had to use a mobile device
  • I did not do anything about "isolation", as mentioned in other places on the Internet (I don't even see such a setting in my modem config pages)
  • There are reports on the Internet of being able to connect initially at first, but then the Chromecast loses the connection after a short while.  In my case, it seems able to cast for at least a full TV show episode (20 to 30 minutes).  I am also able to reconnect after a long period of time (e.g. overnight).  Granted, it doesn't STAY connected, but I don't think it's such a big deal to tap the rectangular casting icon each day.  It takes, what, 5 seconds to reconnect?
  • At first, Shomi didn't have the Chromecast icon, but after fiddling alot with the various Chromecast-aware apps (opening, closing, restarting, etc.), eventually all my Chromecasting apps were working fine, detecting the older-gen Chromecast.

Hope this helps others.

 

At this point, I'm just waiting to see if the older-gen Chromecast holds up for a few more days without problems, then I'll return the new-gen one I just bought.

 

If anyone can tell me how to determine my router/modem firmware version, I will update this post with my version.  (Found it with some help.)

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

When you log into a CGN3 series modem, the Status .... System Information page comes up first.  On that page the "Software Version" is the actual firmware version that is loaded.



Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

sdfasf
I Plan to Stick Around

Hi,

 

Does anyone know how to request the firmware rollback on the website here? who do i message?

We Want Your Opinion
Would you be interested in becoming a Community Testing Lab member?
Topic Stats