CGN3 (Rogers Advanced WiFi Modem) "DNS" issues

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Teksavvy
I've Been Around
Posts: 1

Re: CGN3 (Rogers Advanced WiFi Modem) "DNS" issues

Ok, SO, I am another "not-completely-satisfied" rogers customer who recently upgraded to the so-called Advanced Wifi Modem (not sure how advanced it is) and to Fibre 60 internet pacakge.

 

The speed is defenietly not 60 Mbps (tried both Wifi and LAN). Anyway, I can live with all that but what disappoints me the most is with this upgrade to the new Modem, I cannot access my US netflix on my Ipad and Sony Player simply because the DNS that I got from Unblock-US when I purchased US Netflix account is not being supported by these new "advanced" modems (unlike previous standard Modem).  

 

I tried updating the DNS on my IPad and Modem in a same way that I did for my previous "not advanced" modem (cusadmin/password). But after that, the Netflix account was not getting connected and I had to reset it to access my Canadian Netflix account only.

 

Not sure if anyone else is experiencing similar problems. If this issue has been or can be resolved, I will really appreciate some assistance and guidance. If Rogers is purposely stopping its clients to use US netflix by taking these freedoms and flexibilities away from them then I am not sure how long will they be able to retain these clients.

 

One thing is for sure: Rogers never stops surprising its clients (one way or another).

Gdkitty
Resident Expert
Resident Expert
Posts: 14,321

Re: CGN3 (Rogers Advanced WiFi Modem) "DNS" issues

The main thing with unblock us, is it requires you to use a 3rd party DNS.

The rogers gateway doesnt BLOCK the use of a 3rd party DNS, at least on the client side. 
I currently run 3/4 of my PCs with the GOOGLE DNS server, and all lookup results go through the google dns, and not the rogers DNS that is built into the CGN3.

 

Now, how long have you had the CGN3?  I am wondering if its not on the newest firmware, and if that is caussing some issue.

 

I am not sure, if changing in on the actuall gateway, actualy does change it or not.
You have tried chaning it on the device side only?

 

Alternatively, if you have a 3rd party router.. you can put the CGN3 into bridged mode.  Then use the 3rd party router, which then allows for ANY DNS to be entered.



wayner92
I'm a Reliable Contributor
Posts: 366

Re: CGN3 (Rogers Advanced WiFi Modem) "DNS" issues

I use Unblockus ahd have for a few years and I don't have issues using it with this device, although I have the CGN3 in bridge mode.

 

I implement Unblockus by changing the DNS settings on my individual devices (iPads, PCs, etc) rather than on the router.  And I don't have issues.

 

After you change the DNS on your device, like an iPad, make sure that you go to the Unblockus site on your iPad (or whatever) and check that the service is working.  You may have to log in again.  I have found that when playing around with network settings that Unblockus can no longer figure out what user you are so you have to relogin.