cancel
Showing results for 
Search instead for 
Did you mean: 

Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

testagain
I Plan to Stick Around

Windows Vista laptop was accessing Internet via wilreless without any problem with the modem came with previous Rogers plan. Upgraded plan and now it is not able to access Internet via the new CGN3ACSMR modem. Other devices are working fine via WIFI.

 

Vista gets a valid IP address via DHCP successfully, however the connection type is local only. It is able to ping its own IP, but not the IP of the modem, or other devices. From other devices, they are able to ping modem. Wired connection works fine. Tired restore modem to factory default settings and it didn't help.

 

The laptop has the latest wireless adaptor driver. Windows eventviewer doesn't report any error.

 

Tested the Vista laptop with a Bell modem and Roger CGN2, in both cases, Vista was able access internet without any problem via WIFI. 

 

Is there an admin user in CGN3ACSMR  with higher privilidege than cusadmin? I would like to see more logging at the modem side.

 

In Hitron's site, it clearly says it supports vista on this model. Any input is welcome.

25 REPLIES 25

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

Datalink
Resident Expert
Resident Expert

Try deleting any existing wifi profiles on the laptop, and then reconnect the laptop, as is shown in the following page:

 

http://www.tp-link.us/faq-214.html

 

 



Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

testagain
I Plan to Stick Around

Thanks. Already tried this. It didn't help.

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

Is there any chance that the laptop has an IP address that is set in the laptop, as opposed to automtically accepting the IP address that the modem or router should assign?



Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

testagain
I Plan to Stick Around

Thank you Datalink. 

 

No. I try use 10.0.0.x and 192.168.0.x (default one), Vista is able to pick up a valid DHCP client IP; but no internet access.

Also tried to manually set an IP in 10.0.0.x range and no luck to Internet.

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

Hi @estagain,

 


Thank You for your post, I just wanted to add my insight on this situation.

 

So far I understand your Vista laptop connects fine to the new Hitron CGN3 modem's Wi-Fi but not able to access the Internet. The same Vista laptop connects fine to the Internet through other Wi-Fi's. Just to break it down a little more, try testing the laptop through Ethernet to see if it's able to connect to the Internet. If this works fine, you just need to delete the Wi-Fi SSID and change the password again (see information below):

 

Reset Home Networking Modem Password for Hitron CGN3 or CGN3ACR

  1. Directly connect an Ethernet cable from the modem to the computer.
  2. Open a web browser and enter the following address to access the gateway login page: 192.168.0.1.
  3. Login with:
    • Username: cusadmin
    • Password: password
  4. Click the Wireless link located at the top of the page.
  5. Click on the WPS & Security tab.
  6. If you have forgotten your Wi-Fi password, note the password located in the Pass phrase field.
    • If you want to have your Wi-Fi password reset, enter the new password in the Pass phrase field, and then click Save Changes.
    • Note: Once the Wi-Fi password has been changed, all wireless devices will have to reconnect to the wireless network.
  7. Once the device is connected to the wireless network, confirm the connection by test two separate web pages.

 

Let us know if this works,
RogersArthur

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

testagain
I Plan to Stick Around

You are correct RogersAuthur. The same Vista laptop just don't work with the new modem via WIFI. Wired connection works fine.

 

I have already tried to empty all the existing SSIDs, also tried change the wireless password. However I haven't try them together, and I will give it a try today.

 

I am just curious what does your steps actually fix? Does it reflush/refresh some Vista wireless settings? Would you mind share a related link?

 

Also is there a list of available firmware versions and fixes? cusadmin doesn't have the rights to update firmware. I saw the issue with League of Legends was fixed by Hitron.

 

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

Hi @testagain,

 

 

Good to hear your laptop connects to the Internet through Ethernet, It looks like you've narrowed it down to two things:

 

1) The Vista laptop is having Wi-Fi compatibility issues with the Hitron CGN3 modem, in which case a modem firmware or a laptop Wi-Fi network driver update may fix this issue.

 

- OR -

 

2) The Vista laptop is having an issue with the Wi-Fi's security. This is something I've come across before, where I've seen things from the limited or no connectivity error to Wi-Fi is connected fine but page could not be displayed error. In this case it could be the routers Wi-Fi security and re-configuring the Wi-Fi (change both SSID and password) seems to sometimes fix the issue.

 

I actually don't have a related link that I could point you to but if you do an online search for "Wi-Fi connects fine but no Internet access". I'm sure you'll come across similar Wi-Fi issues ranging from laptops running other OS's to cellular phones and tablets.

 

 

Let us know if this helps,

RogersArthur

 

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

Have you tried to run a Winsock reset command to see if that solves the problem?  Hers's a reference that has a Windows 7 and Vista section in it.  You will need to have the command prompt up as an administrator.

 

https://support.microsoft.com/en-us/kb/299357

 

Can you also run a  ipconfig/all command, copy the results and paste that into the thread.  Maybe there is a clue buried in the data that might help.  You can use a right click at the top of the command prompt window to Edit..... Select All of the contents, and then do it again to Edit.....Copy the contents.

 

 



Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

testagain
I Plan to Stick Around

Thanks Arthur. It still doesn't work after trying your suggestion.

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

testagain
I Plan to Stick Around

Tried the patch, Vista still can't connect to Internet. Output of ipconfig:

 

C:> ipconfig

Windows IP Configuration


Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : hitronhub.home
IPv4 Address. . . . . . . . . . . : 10.10.10.110
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.10.10.1

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : hitronhub.home

Tunnel adapter Local Area Connection* 7:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 12:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 11:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 13:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 14:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 15:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 16:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 18:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 19:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection*:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : hitronhub.home

Tunnel adapter Local Area Connection* 22:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 23:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 25:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 26:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

testagain
I Plan to Stick Around

C:\>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : wc1-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : hitronhub.home

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : hitronhub.home
Description . . . . . . . . . . . : Atheros Wireless Network Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 10.10.10.110(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : July-20-15 1:23:20 PM
Lease Expires . . . . . . . . . . : July-27-15 1:23:20 PM
Default Gateway . . . . . . . . . : 10.10.10.1
DHCP Server . . . . . . . . . . . : 10.10.10.1
DNS Servers . . . . . . . . . . . : 10.10.10.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : hitronhub.home
Description . . . . . . . . . . . : Intel(R) 82566MM Gigabit Network Connecti
on
Physical Address. . . . . . . . . : 00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 7:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : isatap.{12E5D5B6-A3A8-4AC8-A85E-02AD7DE33
B89}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 12:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : isatap.{D6305944-F86F-4D03-8D8B-D43581F76
DAC}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 11:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 13:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 14:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 15:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #5
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 16:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #6
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 18:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #7
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 19:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #8
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection*:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : hitronhub.home
Description . . . . . . . . . . . : isatap.hitronhub.home
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 22:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : isatap.{D6305944-F86F-4D03-8D8B-D43581F76
DAC}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 23:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : isatap.{D6305944-F86F-4D03-8D8B-D43581F76
DAC}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 25:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : isatap.{D6305944-F86F-4D03-8D8B-D43581F76
DAC}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 26:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : isatap.{D6305944-F86F-4D03-8D8B-D43581F76
DAC}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

Hello, @testagain

 

Thank you for try the different troubleshooting steps to resolve the problem.

 

I am assuming the other devices are getting connected on WiFi fine and the issue only is with the Vista laptop.

 

I have worked with many Vista laptops and in my experience connecting them on WiFi with the highest encryption could be challenging. We can try few different steps in an attempt to find the solution.

 

Before you begin the process I’m listing below, I would recommend taking the Backup of router config file so that your current network can be restore after testing is done.

 

It’s not recommended to lower the security but for testing purpose, would you please try the following;

 

  1.  Create a new WiFi network with WPA/TKIP configuration and try connecting your vista laptop. 
  2.  Can you try creating another network with WEP configuration and try connecting. 
  3.  You can also try connecting without encryption. 

 

If you can browse the internet in any of the above 3 steps, then please try updating the wireless adapter drivers on your laptop.

 

Let us know if you need any assistance, I can have a team member from @CommunityHelps reach you out through Private Message.

 

Thanks,

RogersMoin

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

When you say that you tried the patch, is this the one that you are referring to:

 

https://support.microsoft.com/en-us/kb/935222

 

Trying to establish a link with a lesser encryption mode is a good idea.  It might prove what is indicated in the thread above, but at this time I don't know if you have done the Microsoft Hotfix as of yet. 

 

Have a look at the following thread and read down thru the thread starting further down at jonh's post from 26 Apr 2012:

 

http://www.tomshardware.com/forum/31932-43-wireless-connection-through-hard-wire

 

 

Here is something else interesting.  Looking through your 2nd IPCONFIG data group, there is no MAC address for your Atheros wifi adapter.  I'm not sure how a router should react to a device that doesn't have a MAC address.  So, this is a little strange.  Here's the lines that I am referring to:

 

Description . . . . . . . . . . . : Atheros Wireless Network Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00

 

 

Why does that indicate Adapter #2, instead of just Adapter?



Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

testagain
I Plan to Stick Around

Thank you Datalink. No I tried the one patch you mentioned in your last reply:

https://support.microsoft.com/en-us/kb/299357

 

I will try this one.

 

Not sure why Vista says it is #2? I have tried to remove the adpator and Vista add it back as #2.

 

I didn't notice the all 0 mac, on the modem managment page, it does list the proper MAC address for wireless adpater.

 

Will let you know.

 

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

testagain
I Plan to Stick Around

Downloaded and unzip the fix 935222 succesfully. However installation prompts "The update does not apply to your system".

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

testagain
I Plan to Stick Around

Hi Moin,

Thanks for the reply. This modem CGN3ACSMR only has WPA-PSK or WPA2-PSK. It doesn't have TKIP. The funny thing is that Vista is able to connect to WPA2 with limited connectivity, however it fails to connect to Modem if auth mode set to WPA.

 

Tried 2.4GHz open, it works without problem! What does it tell us?

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

That's kind of interesting.  If your Vista laptop connects with other routers or modems using WPA2-AES for encryption, and doesn't with the Hitron but connects with an open network, then, yup, there is some compatibility problem.  To be fair however, without knowing the details of the encryption implementation of the Hitron, I don't think that one can simply say the Hitron is solely at fault.  Given the fact that Windows XP and Vista development stopped some time ago, I would think that other modems or routers are possibly being generous in terms of their backwards compatibility that someone with a Vista PC or Laptop still running still connects and utilizes those modems or routers.  Its possible that you might see this same issue with other modems or routers as well.  Personal opinion, I think I would have looked at loading some variety of Linux to be able to keep using the laptop and keep it secure, given the miscreants on the loose creating malware these days.  That might be food for thought if you want to keep using the laptop via wifi.  Or, bridge the modem and use your own router.  

 

No TKIP on the modem?  Glad to see that actually as TKIP is no longer secure.  Thats interesting as the CGNV4 modem, which should be very close to this in terms of firmware has TKIP and TKIP/AES listed as available.



Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

Hello, @testagain

 

I would go with the suggestions provided by Datalink, as I’ve stated in the previous post lowering the security is not recommended. If you still want to create a network with a WPA/TKIP configuration, I can have CommunityHelps contact you.

 

Cheers,

RogersMoin

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

learningful
I'm Here A Lot

I am trying to change my wi-fi password for my CGN3ACSMR. Rogers does not provide a login address for this specific modem, and the address provided for the CGN3ACR (http://192.168.0.1) seems to be incorrect, since I can't connect.

 

Any suggestions would be appreciated. Thanks

 

Re: Any known compatibility WIFI issue with CGN3ACSMR modem and Windows vista?

just use 192.168.0.1, no http://  prefix

 

username:  cusadmin

 

password:  as provided by the tech.   Default password is password