90/2 Ultimate -- Why am I not getting 150/10?

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Here Awhile
Posts: 2

90/2 Ultimate -- Why am I not getting 150/10?

I've called 7 different reps, all telling me its setup correctly for 150/10 on their end. 
I directly connect to the modem, and while i'm on the phone with the rep I get 139/2 speeds; after i'm done speaking with him 
it goes back to 80/2 speeds.

I was told to get a new modem, I did and i'm still not getting these speeds.
Rogers told me that the 2.0mbps upload being the same is likely due to load and time of day.
I've had to call 7 people to end up paying for a new modem and back at square one with my ultimate internet. 


Poor CS:Service when my problem keeps getting pushed to another person. 

 

 

***edited labels***

Solved! Go to Solution.
Resident Expert
Resident Expert
Posts: 14,031

Re: 90/2 Ultimate -- Why am I not getting 150/10?

And you are using one of the D3 gateway modems?  Hitron, SMC, Cisco? (just confirming to illiminate that out)



Highlighted
I've Been Here Awhile
Posts: 2

Re: 90/2 Ultimate -- Why am I not getting 150/10?

Hitron was the one I exchanged for yes.

I was assured my account was setup correctly for 150/10 but yet  i get the same speeds I had before a router change. 

Resident Expert
Resident Expert
Posts: 14,031

Re: 90/2 Ultimate -- Why am I not getting 150/10?

Maybe call and double check :(.

There are two plans for each net speed, the old plan speed with the d2 modems and the new plan speed with the d3s.

You can have the old plan on a d3 though 😞