cancel
Showing results for 
Search instead for 
Did you mean: 

8642HD HDMI output does not delivery 5.1 audio stream - stereo only

techguy001
I'm a Reliable Contributor

Has anyone else noticed that the HDMI feed from the 8642HD PVR only delivers 2-channel digital audio?

 

This has been true for a while now but forgot to post a question on this to see if anyone else noticed this.

 

My 8642HD PVR with Enhanced Guide software is set up to send out 5.1 audio channels in its settings but this only seems to work over the Toslink optical connection.   I'm forced to have 2 connections to my digital processor, one for HDMI video switching then out to my display and a 2nd Toslink connection to get the 5.1 Dolby Digital audio signal.    Seems silly given that HDMI is fully capable of delivering the same 5.1 Dolby Digital signal over its wires and therefore would avoid a 2nd connection for the same source.

 

I have other source devices that feed HDMI video and audio to my processor and all work fine with all types of digital audio (ie. 2-channel PCM, Dolby Digital 5.1, DTS 5.1, 5.1 channel PCM, DTS HD Master Audio and Dolby True HD).

 

 

 

 

***Edited labels***

 

 

 

 

 

7 REPLIES 7

Re: 8642HD HDMI output does not delivery 5.1 audio stream - stereo only

Gdkitty
Resident Expert
Resident Expert

My reciver, auto switches modes when a device is plugged in, based on what it is broadcasting.

Not at home, so i cant confirm.. but i am pretty sure mine switches to full 5.1, last i actualy paid attention. (i get audio from the rear speakers)

I know when i had my Wii into the receiver, that it came up as 2 channel PCM (forced it over to full stereo surround).. but its plugged in via stereo RCA only.

 

Could it be feed based? Not all channels may broadcast their signal with the 5.1 surround?

For regular TV, i dont normaly have my receiver on.. only if watching a movie on the TV, etc.. so i dont really look at it too often to 100% remember.

Re: 8642HD HDMI output does not delivery 5.1 audio stream - stereo only

Just comparing to this thread from before...

http://communityforums.rogers.com/t5/forums/forumtopicpage/board-id/PVR_settop_boxes_remotes/thread-...

Mind you its rather old.. but may still apply.

Only SOME channels push out 5.1.

 

But on those ones, you SHOULD get it via HDMI.

http://www.rogers.com/web/Rogers.portal?_nfpb=true&Ntt=personaltv&_pageLabel=search&N=89+4294966661+...

Second point on here.. confirms only some output 5.1.

But again.. SHOULD work on HDMI.

Hmmmmmmmm..... how old is the HDMI cable? maybe make sure its a hdmi 1.4 cable, just to make sure its getting everything? (IE, i know the hdmi 1.0 cables, etc dont support ARC, etc).

Re: 8642HD HDMI output does not delivery 5.1 audio stream - stereo only

techguy001
I'm a Reliable Contributor

Yes, I'm aware that not all channels broadcast 5.1 but most HD channels do.   I'm comparing those that do.   

 

My system is high-end and hast the latest and greatest capabilities, including HDMI 1.4a support and supports all the known current audio digital streams.    My cables match that,  however you don't need the current standard to support Dolby Digital 5.1.  Even HDMI version 1 did that given how old Dolby Digital 5.1 standard is.   

 

I use a computer for all of my media consumption outside of cable and I can send any kind of audio stream to my digital processor via HDMI 1.4a.

 

I  have verified by doing a lot of testing with the Cisco 8642HD that I'm only getting 2-channel digital streaming from HDMI while at the same time getting 5.1 Dolby Digital from the toslink optical feed (which I've been using for a while now given this problem).   As I recall even the 8300HD older box had this limitation as well.

 

 

Re: 8642HD HDMI output does not delivery 5.1 audio stream - stereo only

Im not doubting you.. just going from my experience, and the documents provided 🙂 

If i get a chance, i will try and take a look at mine, to see what it is showing (if i am correct, my receiver has an input display which will show what input it is getting.)

 

I'll post back my results, once i can get them.

 

Re: 8642HD HDMI output does not delivery 5.1 audio stream - stereo only

OK, did some tests.

 

When the TV turned on, it was on The Weather Network.. SD channel, definately no 5.1 with it.
Went into info on my receiver.  Showed as 2 ch dolby.

 

Changed to ch 59, my SpaceHD channel.  Was airing Star Trek Voyager, an SD show, but did hear an audible change. 

Went into the info on the receiver.  It showed at 5.1 dolby.

 

Went to DisneyXD which is an HD channel.  Showed only 2 ch.

 

Went to DiscoveryHD, and it showed 5.1.

So, it DOES varry based on channel. And my reciever is picking up the difference/change between channels.

Audio settings are : dolby digital, normal and fixed.

 

Do you have thew NEW or the OLD guide? 

Re: 8642HD HDMI output does not delivery 5.1 audio stream - stereo only

techguy001
I'm a Reliable Contributor

thanks for doing that  Gditty.   We are not getting the same results if that's the case.

 

I'm using enhanced guide since last year so my unit is as up to date as I think it can be.   My digital processor also shows what's coming in for audio streams.

 

I only get PCM 2 channel audio stream at 48Khz sampling rate coming in from HDMI on  Rogers box regardless of channel even though the audio settings on the unit are set to output Dolby digital  5.1.

 

As soon as I switch the audio source to the Toslink optical feed from the same Rogers box I get the expected Dolby Digital 5.1.

 

You would expect both to output the same stream but it would seem that on HDMI my Rogers box is converting the sound before outputting it.

Re: 8642HD HDMI output does not delivery 5.1 audio stream - stereo only

Hm.. that is odd.


I am using the enhanced guide, since about the first day the whole home PVR came out, so about the same timeframe as you.

 

Just to expand more on my receiver.  When on an input, you can go through, and change what the output is.. like yours, mines set to 5.1 DD for the output.
There is no way to change the 'input' that i can see, in case that would effect anything.

Within that same menu set, there are options to view the 'info' on that input.. audio, video, etc. 

Video shows at it comming in at 1920x1080, and output set the same.
From changing channels, under the audio portion.. shows both the IN and the OUT.
OUT always stayed the same, as its what i have it set to do.  but for the input.. as i changed on the channels i described above.. it would change from showing 2 channel, to 5.1 on the input.

 

So SOMETHING is different.. weither hardware.. software.. or something..
You have the same general audio settings in the guide?
Not that is SHOULD effect this in anyways.. i have the whole home PVR addon..

Guessing its not a rental box?

Topic Stats
  • 7 replies
  • 4063 views
  • 0 Likes
  • 2 in conversation