I have bought a sim activated it online and it's still not registering (iPhone 4s)

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Here Awhile
Posts: 2

I have bought a sim activated it online and it's still not registering (iPhone 4s)

Hey I have just purchased a new pay as you go sim and went through the gears of activating it online and it said that its activating in my phone and would take an hour but its been about 3 now and it's still not going it just says no service on the top left. Just wondering if anyone knows what's up or if someone else is having this problem or had it and fixed thanks guys

 

****Edited Labels****

Solved! Go to Solution.
I'm a Trusted Advisor
Posts: 31,998

Re: I have bought a sim activated it online and it's still not registering (iPhone 4s)

Hello Bjparise

Have you tried turning off the phone and turning it back on?. Also have you tried contacting Rogers PayGo reps to see what's going on?
I've Been Here Awhile
Posts: 2

Re: I have bought a sim activated it online and it's still not registering (iPhone 4s)

Got it working thanks. Know anything about finding the 4 digit passcode?
I've Been Around
Posts: 1

Re: I have bought a sim activated it online and it's still not registering (iPhone 4s)

Hi Meowmix,

Thanks for sharing this. I just changed my SIM card number online for an IPhone 6, then turned the phone off, then back on and it worked.
I'm a Trusted Advisor
Posts: 31,998

Re: I have bought a sim activated it online and it's still not registering (iPhone 4s)

Hello @Ejoremi

That is great to hear! You are welcome Smiley Happy