MMS not working with android

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
Showing results for 
Search instead for 
Did you mean: 
I Plan to Stick Around
Posts: 28

Re: MMS not working with android

also our porting in took a bit, she was on the phone will bell and then it finally went through. i told the tech that

I Plan to Stick Around
Posts: 28

Re: MMS not working with android

since taking to the last tech, dave, he said he wasnt sure why my phone wont send, he did a network reboot and since ive gotten off the phone with him, my phone is sending/receiving with no fail rate. ive tested it over and over and its good. hopefully this is it !


i am using YAATA with a fresh install and its working great too. 

I'm a Senior Advisor
Posts: 2,154

Re: MMS not working with android

Great it is working - rest may have changed a setting in MMS ATM setting.


See this set of posts from T-Mobile on the issue.


They recommend the following change -
Leave out the quote markes

APN type - " default,mms,supl"

APN protocol - " IPv6/IPv4

APN roaming protocol - " IPv6/IPv4


Note, on my phones, APN roaming was IPv4 only.


My guess - since it is trying to find data and can't access due to connection to WIFI as it is looking only to IPv4, it goes to WIF and it can't run.


Rogers cellular network is on IPv6 now, and once you turn off the WIFI, it is able to grab the IPV4=6 in the first setting.


 You will need to create a new APN, because the SIM network settings will override the changes and keep setting it back.
Will keep you up to date - I have changed mine and not my wife's.
Interesting thing is that this issue was identified and resolved with T-Mobile in January 2017 - I just ran into it today, because I didn't think to look at other networks in US for solutions.
Does Rogers not read technical notes for other companies, or even use Google when trying to solve the problem.
Take a look at your APN settings under settings access point names, and see since they did the network rest, is setting now IPV4 and IPV6.  Mine was IPV4 only before I changed it.
Once again, community forums members do the problem solving, spin their wheels with support, and often the solution comes from our work.
I miss the days of Blackberry - they did not give final control over final settings and documentation to the carriers.
They had all vendors provide their network specs and Blackberry tested what was given to them, and then they had documentation on all companies at their reach.  Now each network does their own thing, and confirms final with company, then it is all in hands of the network on network issues, so Rogers does not know what is going on when they make similiar changes as other networks.
Thanks, I will update you over the next few days, and then document it more fully.
This issues has been reported since 2016 by the way.  2017 was about time that ours started.
Note there are also mentioned issues about wifi calling being set at wifi preferred which turns off LTE access - in the T-Mobile notes.
I'm a Senior Advisor
Posts: 2,154

Re: MMS not working with android

Final update on this issue for the night - after doing extensive google search (well not really - just did the following search rogers mms "ipv6"  which means search for posts with rogers, mms, including ipv6.


Discussion since 2013 on this topic including one from RogersDave network engineer, now moved on to Hitron.


In 2013 - some phones did not support IPv6 and all network settings were set to use IPV4 only and many phones only had that capability.


Phones began to come into play in 2013 and 2014 with LTE capability but many networks were not using IPV6 yet, so you had to be sure on newer phones, the settings were IPV4 only in the APN settings (see my earlier post).


Then IPV6 comes along, people start having issues - network provisioning for MMS from Rogers is changed to include IPV4, IPV6, or both - set as both by default in provisioning to your phone and account on network for APM MMS, but roamin was left as IPv4 by default - choice was there.


Now WIFI calling comes into play and from reading, when set to WIFI calling WIFI preferred, the MMS data would try to send to the WIFI, but obviously it can't be sent via WIFI - phone and SMS can.  So, it roams looking for a connection, but IPV4 is the setting on roaming, so it can't connnect to the LTE data on IPV6.


Lots of discussion over last 4 years about need to set both to IPV4 and 6, even on rogers Forums boards.


But Rogers APN settings on support when you search does not speak to the IPV4 6 issue at all, just gives the ip address settings (all IPV4 - or gives the domain addresses - by default provisioning does not use IPV6 or 4, but uses domain addresses, which is best practice as addresses can change, but companies rarely change domain address (DNS).


So to fix the problem - change those settings - you will not be able to edit the default Rogers APN settings, these are provisioned from network and may occasionally reset back to default, except that it seems that in @janice11 's last interaction, they reset the network provisioning and pushed out the new settings and these are ipv6 and 4 I would guess - it can be checked.  As it should be.


Give this a try - if talking to the tech and engineers again, run this by them and talk about lack of knowledge of this by support level 1 and 2 and even higher levels, - an engineer would probably figure it out, but this is known information and needs to be documented into the support pages - if you take a look at 7-11 and Petro Canada, you will find they have the full settings for their network connection, including the APN IP versions settings.


So, if this is the ultimate issue, - seems to be, my wife's is working great now too.  No delays at all.


Just have to remember to turn on data as we don't use it most of the time. 


If this is the solution, Rogers needs to change the reference page for APN settings and include all settings including theAPN protocol and Apn roaming protocol.


My guess is that it is those of us who  started life using MMS a lot and staying away from email and facebook and other ways to send it, and then when protocols changed, we got problems coming into play along with WIFI calling - wifi preferred.  So it is not a common issue for many - many have data and just use what's app - data based, facebook - databased, fb messenger data based, and so on, and drifted away from MMS.


Hope this is the solution.  If it is, please mods get it added to the help blog pages, and please advise Rogers support department, engineers, and change up the APN setting page and you will need to address older phones too that don't have IPv6 capability - see tmobile in 2003 for early information.


Good night all. 


I love a good IT networking problem, but get frustrated when the provider companies and vendors when it appears that they have not kept themselves updated in their support documents.


Oh well, my little bit of contribution to the problem.


Give it try and see if it helps, and please support and engineering and how to writers, lease research this and update all documentation.  It is clearly incomplete.



I Plan to Stick Around
Posts: 28

Re: MMS not working with android

im happy to say our phones are working beautifully with the MMS. my phone since yesterday still has a 0 failure rate. i was testing it with my husband and other ppl and it appears to be fixed ! when the tech calls me today im going to tell him to not do anything . haha ! 


thank you Bruce for your insight and knowledge, when the tech calls im going to tell him everything you said. i appreciate your help.


Fokker22, maybe tell them to do a network reset/reboot, hopefully that fixes your problem too. 


i want to also say rogers has been great as well. even with my frustration, they were/are very good to work with. i am hoping this has been fixed now.  thanks to everyone here as well.



I Plan to Stick Around
Posts: 15

Re: MMS not working with android

I am glad that every thing worked out for you. I hope for your sake that it stays that way! I unfortunately am still in limbo. I spoke with a tech assigned to me 2 days ago and haven't heard. I mentioned via email some fixes that both you and Bruce had suggested and I also mentioned as well that they would be wise to consult the forums.
Good luck and thanks!!
I'm a Senior Advisor
Posts: 2,154

Re: MMS not working with android

3 days and all is fine with APN roaming ip set to IPV4/IPV6.  Lots of reading mostly from T-Mobile raised that WIFI calling set to WIFI preferred led to MMS data trying to go down WIFI which can't work - T-Mobile recommends a few options which we hae heard some of them


Turn WIFI Calling off when doing MMS

Set WIFI calling to cellular preferred - just means that if cellular is there, but flakey, it will be bouncing back and forth and defeats benefit of WIFI calling in poor cellular locations, which is you don't hae cellular you won't be able to send an MMS or receive either or calls.


Turnj WIFI off.  This issue has been around since 2013 and never existed before WIFI calling was in place until 2015 for most companies, and this may not be a wide spread issue for some as many people are using data plans and using alternatives to MMS (example Facebook).


There were even MMS alternative apps for a while that automatically turned off WIFI when an MMS was triggered, or they set up MMS only APN's removing data and kept two profiles and the app allowed you to switch within the app, turning it on and then off. 


Some companies like T-mobile originally allowed MMS over WIFI and probably why it was a bigger issue for them, but then with a change in how MMS worked on Android, they had to stop and move, but they debugged it and talked about it from about 2015 onwards.


Only problem the switch over has created, ;my wife was out of habit of using MMS, and when she suddenly could, she has low data limits and highly restricted app use on data - WiFI only options as much as possible, so she would turn on data, do the MMS or download it, and then turn data off, but she stopped due to the failures of late.


She forgot to turn data off and we had to get a data top up - I leave a comment on that process of data top up for that thread.


Fingers are crossed - I hope Rogers engineers are testing and confirming some of this stuff and eventually get support docs out for all.


But is sounds like fur Janice, a reset of provisioning solved the issue.  In effect, I reset the provisioning on my own.


@janice11  Could you check you settings and go to more under general and go to mobile networks access point names, and open the access point and see what is in APN protocol and Apn roaming protocol now that they reset yours - would confirm if I am on the right track about the IPv6 requirement or not. Or is it just coincidence?


Thanks for the opportunity to work my past IT and telecom brain.   IPV6 was nothing but a hypothetical protocol when I left the field.  I am still learning.l


Thanks everyone.



I Plan to Stick Around
Posts: 28

Re: MMS not working with android

our phones are still working great ! 


bruce, with the phones. in that area it said ipv6/ipv4 . one tech person i spoke to made me add something there and now it says ipv4.