Google Pixel 2 XL - not connecting to LTE

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Here Awhile
Posts: 2

Google Pixel 2 XL - not connecting to LTE

Hey there. I have 2 Google Pixel 2 XL's provided by Rogers and one of them works perfectly with LTE while the other will not connect. I have mirrored the settings with LTE preffered in the network settings before restarting and checking to make sure it saved. Upon checking it remained on LTE preffered; however I can have the two phones beside each other and only the one will connect to LTE. I have a good base knowledge of the devices to work off of on this end! Would love some expert help figuring this one out, thanks!

 

*Added Labels*

Moderator
Moderator
Posts: 1,534

Re: Google Pixel 2 XL - not connecting to LTE

Hello, @Dexo.

 

Welcome to the Rogers Community Forums! 🙂


Thank you for posting your concern in the Community. One of your Google Pixel 2 XL not connecting to LTE is puzzling; I appreciate mirroring the settings from the other phone. However, since it's a Rogers' device, it should acquire all the required network settings upon coming online the first time. 

 

Since how long are you experiencing this issue? 

 

Have you tried swapping the SIM? 

 

Like you can try the SIM from the phone connecting to LTE into the phone not connecting to LTE to see if it can connect to LTE. 

 

Keep us posted with the outcome. 

 

Cheers,

RogersMoin
 

 

I've Been Here Awhile
Posts: 2

Re: Google Pixel 2 XL - not connecting to LTE

Hey ! Sorry for the delay, had to wait for my wife. Not 100% sure but we believe it had to have been since we got the phones as it has been on wifi essentially 98% of the time. We only really noticed during a major storm that knocked out power for an extended period of time. During that we noticed as mine was able to load updates from the power company while her's couldn't load anything at all.

Anyways as for the Sim card swap! I swapped the Sim cards and checked. My sim card in her phone allowed it to connect to LTE while her Sim in my phone would not connect to LTE. Essentially passing the state from one phone to the other. Thus it must be the Sim card preventing the LTE connection and not the phones themselves.

What would the fix be? Is it as simple as calling the tech support team for Rogers or will it require a replacement sim card?
Moderator
Moderator
Posts: 2,038

Re: Google Pixel 2 XL - not connecting to LTE

Thank you so much for your reply @Dexo!

We appreciate you took the time to validate these details.

 

Since the issue seems specific to her line, it could be at the account level. Are you both on the same account?

 

In the instance where she exceeded her data plan allowance, for example, it could have been temporarily suspended until the billing cycle starts over.

 

Do you use the data manager? An alert could have been set for her specific line.

 

Before requesting a replacement SIM card, please allow us a chance to look into this further.

Since we now know the issue is not hardware-related, we'll need to discuss privately to gain access to your account.

Please send a PM to @CommunityHelps if you would like us to assist you resolve this. For more information on our Private Message system, please check out this page.

 

Regards,

 

RogersMaude