Galaxy S2 LTE not receiving calls on LTE network

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I'm a Trusted Contributor
Posts: 903

Re: Galaxy S2 LTE not receiving calls on LTE network


@peter123 wrote:
im in ottawa as well (kanata) had let problems since day 1. first they saidf it was my device. Even though it worked perfectly in toronto and and few spots in ottawa. they told me were theit towers were in relation to me. i drove out there turned navigatuion on and took screen shots of my phone and it clearly shows the phone not going into lte mode. they finally admitted their "may" be a networ issue after u emailed tech support the pics

Peter, this is my comment on the LTESpeed forum...from about half an hour ago;


@-Riz- wrote:

My S2LTE is not connecting at all to the internet .. despite it being on LTE or 4G, tried disconnecting the networks and changing to GSM only as well. Anyone else experiencing issues right now? Network down?



I posted a New Topic...on Friday, but it was either removed or moved, about connectivity issues.  My phone was showing 4G and 3-4 Bars, but I could not navigate anywhere...As I type this, I have been trying to signin to rogers on my phone again, it's showing between 4 & 5 bars at 4G, but it's just hanging there?  ( I am posting from my p.c.).

I spoke to a tech, who escalated my call because BOTH my rocket stick & my Gsll were showing about 4 Bars, but could not navigate anywhere...I have NEVER seen that before!  I would understand it if there were no bars and no signal, and I can see Parliament Hill, from where I am...AND according tot the tech, I am within 1k of THREE towers!!!!

The tech said that someone would call me back within 72 Hrs.  Still waiting.

Just tried again to sign in to rogers with the phone...gets about half way across and just hangs, same at zdnet's site and cnn??

Like you Riz, I tried switching from "auto LTE" to hspa etc, turned the phone off and on etc.  On Friday the "blackout" for both the Rocketstick and the GSll lasted about 20 Min.

I'm Here A Lot
Posts: 7

Re: Galaxy S2 LTE not receiving calls on LTE network


@shaggyskunk wrote:

@peter123 wrote:
im in ottawa as well (kanata) had let problems since day 1. first they saidf it was my device. Even though it worked perfectly in toronto and and few spots in ottawa. they told me were theit towers were in relation to me. i drove out there turned navigatuion on and took screen shots of my phone and it clearly shows the phone not going into lte mode. they finally admitted their "may" be a networ issue after u emailed tech support the pics

Peter, this is my comment on the LTESpeed forum...from about half an hour ago;


@-Riz- wrote:

My S2LTE is not connecting at all to the internet .. despite it being on LTE or 4G, tried disconnecting the networks and changing to GSM only as well. Anyone else experiencing issues right now? Network down?



I posted a New Topic...on Friday, but it was either removed or moved, about connectivity issues.  My phone was showing 4G and 3-4 Bars, but I could not navigate anywhere...As I type this, I have been trying to signin to rogers on my phone again, it's showing between 4 & 5 bars at 4G, but it's just hanging there?  ( I am posting from my p.c.).

I spoke to a tech, who escalated my call because BOTH my rocket stick & my Gsll were showing about 4 Bars, but could not navigate anywhere...I have NEVER seen that before!  I would understand it if there were no bars and no signal, and I can see Parliament Hill, from where I am...AND according tot the tech, I am within 1k of THREE towers!!!!

The tech said that someone would call me back within 72 Hrs.  Still waiting.

Just tried again to sign in to rogers with the phone...gets about half way across and just hangs, same at zdnet's site and cnn??

Like you Riz, I tried switching from "auto LTE" to hspa etc, turned the phone off and on etc.  On Friday the "blackout" for both the Rocketstick and the GSll lasted about 20 Min.


Hi there .. spoke with a tech support rep again and there is/was an issue this morning. It is resolved now though (as of 10am) as my S2 LTE is back to normal with internet again. Only downside is when tech support didnt know of the issue (around 8am) and I was pulling my hair trying to figure it out ... I reset the phone to factory settings, so lost all my setting and downloads which I will have to redownload. Oh well guess its like a refresh of the phone but at least I know its not the phone thats faulty.

I'm a Trusted Contributor
Posts: 903

Re: Galaxy S2 LTE not receiving calls on LTE network

I am still seeing Edge @ 4Bars...
I Plan to Stick Around
Posts: 18

Re: Galaxy S2 LTE not receiving calls on LTE network

 

After living with this for two weeks now (factory resetting twice, and replacing the phone once), I've come to the conlusion that the GSII LTE gets "confused" depending on the relative signal strength of the LTE and HSPA networks.   My phone will frequently report "Emergency Calls Only" while indicating an LTE signal...  sometimes actively transferring data over the LTE network.   If I then restart the phone, or switch to GSM/HSPA, it will find the HSPA and report 3-4 bars of signal strength.

 

The problem is definitely location dependent....   in my office, I can hold an LTE connection (showing only 1-2 bars) ll day and make and receive calls with problem.   In my home (where four other phones get 3-4 bars on Rogers) the Samsung will show 1-3 bars of LTE, but after a few minutes will show either "No Service" or "Emergency Calls Only".    At a Government building downtown, with strong HSPA signal, and 1-2 bars LTE I was unable to make calls today without turning off LTE (setting to GSM/HSPA).

 

Driving the length of the 417 across Ottawa, my GSII will switch to "No Service" or "Emergency Calls" several times, particularly in the West of the city.

 

I don't believe it's a signal strength issue... I can get good HSPA only reception, and good LTE reception in places....  but the phone gets confused.    To me it looks like a firmware issue, and is likely to require an update to resolve.   For the moment, I'm hoping that Rogers is aware of the issue and that they are working with Samsung on a fix....  but that could take a while.

 

I'd suggest everyone who sees an issue with GSII reception call Rogers support and report it, so that the issue is recognized.  Hopefully Skyrocket users are seeing the  same problem on AT&T's network, so that it has better chance of getting fixed.

 

 

 

I Plan to Stick Around
Posts: 21

Re: Galaxy S2 LTE not receiving calls on LTE network

I live in the Kanata (Ottawa) area inside strong LTE coverage. SGS2LTE worked perfectly on 4G without the LTE functionality with an old, non-LTE SIM card until yesterday. I have upgraded to an LTE plan, inserted the LTE SIM. Since that moment, once my phone receives the LTE signal, I am experiencing complete loss of phone connection, i.e. NO SERVICE and after a few moments EMERGENCY CALLS ONLY, back and forth. Spoke with tech support; she made two changes on my network connection, with no success. Her suggestion was to 1.) factory reset the phone, and 2.) replace it if the reset didn’t help.  Based on what I see in this thread these steps may not resolve this issue, but will do it regardless.

Any positive experience with the factory reset or the phone replacement?

I Plan to Stick Around
Posts: 13

Re: Galaxy S2 LTE not receiving calls on LTE network

Ugh, databubble. You're right that we should call tech support in order to flag it for them...I'm just dreading actually having to call them;)

I Plan to Stick Around
Posts: 21

Re: Galaxy S2 LTE not receiving calls on LTE network

I was wondering if this has anything to do with the downloaded apps. Below you can find my installed apps. If those with subject line connectivity problem have any of those installed, please let us know. Two of my suspects are in red.

 

1.) 24 Soundboard

2.) AbyssFTP

3.) Adobe Flash Player 11.1

4.) Android Assistant

5.) Barcode Scanner

6.) Battery Upgrade

7.) ConvertMe

8.) Dictionary

9.) Droid48

10.) Facebook

11.) FidMe

12.) fuel calculator

13.) Gmail

14.) Maps

15.) Market

16.) MobileVoip

17.) Network Info

18.) Panecal

19.) Shopper

20.) Skype

21.) Speed Test

22.) TeamViewer

23.) urMusic New Releases

24.) WiFi Analyzer

25.) YouTube

 

I Plan to Stick Around
Posts: 18

Re: Galaxy S2 LTE not receiving calls on LTE network

I went through the factory reset and phone replacement without any success.

And at the time of replacement I only had standard apps that come with the phone, nothing extra.

 

I'm wondering if other Rogers LTE phones (not SGII, I don't know what else is in the market) have the same issue; or as mentioned above, is this the phone's problem that that can be fixed by a firmware.

 

I'm a Trusted Advisor
Posts: 32,019

Re: Galaxy S2 LTE not receiving calls on LTE network

Nope my HTC Raider LTE works just fine. My S2 LTE had the same problem with yours.
I Plan to Stick Around
Posts: 21

Re: Galaxy S2 LTE not receiving calls on LTE network

Unfortunately NO CHANGE after factory reset, i.e. no additional app is installed, and my phone has the latest firmware installed, based on KIES... 

 

What I found is the Mobile Network Settings changes automatically to GSM/HSPA mode after a number of "EMERGENCY CALLS ONLY" and "NO SERVICE" cycles while showing LTE connection with all bars grayed out. However, the phone still attempts to connect to LTE, and fails all the time.

 

I will call Rogers Tech Support in a moment...