Galaxy S2 LTE not receiving calls on LTE network

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I Plan to Stick Around
Posts: 21

Re: Galaxy S2 LTE not receiving calls on LTE network


@mcsarang wrote:

@lubiya, I am shocked to hear that even in Downtown Toronto you are having problems with LTE. 

 

I was doing another testing while I was driving up north on Bayview. At Bayview & Hwy 7 in Richmond Hill, I was getting LTE with 3 bar and a resonable spped of around 19Mbps. Between Hwy 7 and 16th on Bayview, I was getting LTE with 1 bar and a slow speed of about 3-6Mbps. At the intersection of Bayviw and 16th, I was getting LTE with 3-4 bars and a fast speed of 30Mbps. Between 16th and Weldrick on Bayview, again I was getting LTE with 1 bar and a very slow speed of 3-6Mbps. 

 

Why should we purchase LTE ready data plan and LTE phone if we can not fully use LTE. I am seriously thinking about selling Galaxy S2 LTE and staying with iPhone 4S. 

 


@mcsarang: Are you experiencing the "No Service" or "Energency Calls Only" issues around the above listed areas? This topic is about absolutely NO LTE connectivity coupled with NO phone connectivity deep inside the LTE covered areas, and the SG S2LTE not being able to switch back from LTE to HSPA or GSM while in "GSM/HSPA/LTE (Auto mode)" when leaving the otherwise LTE covered areas. In 90% of western Ottawa, we wish we could use our phones to make and receive phone calls, or download/upload anything at any speed while on Rogers' LTE network. Rogers LTE network here is completely unusable.

I'm a Trusted Contributor
Posts: 902

Re: Galaxy S2 LTE not receiving calls on LTE network

It's almost always the easiest 1st response "it's the first we hear of this"...
When you call, are they not giving you a Case number?
I Plan to Stick Around
Posts: 21

Re: Galaxy S2 LTE not receiving calls on LTE network


@shaggyskunk wrote:
It's almost always the easiest 1st response "it's the first we hear of this"...
When you call, are they not giving you a Case number?

Actually, I have 2 (still open) ticket numbers already, and 0 problem resolution. The reason why I have two ticket numbers: some of the customer service reps can, some cannot find the first ticket, so I requested to open a second one.

I Plan to Stick Around
Posts: 21

Re: Galaxy S2 LTE not receiving calls on LTE network

UPDATE:

 

Got some positive feedback from two different sources at Rogers: Last night a field technician has tested the sites and was able to reproduce the reported failures along March Road in Kanata. The issue was further escalated to management level.

Today afternoon they made some initial progress: my phone can connect to LTE. (Record DL speed: 27Mbps, UL speed: 7.8Mbps @ two bars... if it stays in this range, I can't wait until Rogers' LTE coverage arrives to the rural areas of Mississipi Mills, I will switch my home ISP to Rogers in a heartbeat!)
 
...Back to the topic: Staying in LTE mode will not put my phone anymore to "Emergency Calls Only" or "No service" state. However, if I want to make a call, or want to receive a call (i.e. call myself from another phone to test phone's reception) it still goes to "Emergency Calls only" state, but after a few seconds it recovers from this state and switches back to LTE without any manual setting or power cycling, as it was necessary before. In order to be able to make and receive phone calls I switch back to GSM only, and switch to LTE for the period I want to browse the internet. 
 
I am positive they will be able to fix this.
I Plan to Stick Around
Posts: 18

Re: Galaxy S2 LTE not receiving calls on LTE network

That's good news. Thanks for the update OMF.

 

Right now I tested my phone and I managed to receive calls while on LTE!

I'll still test it for few more days to make sure it works fine, but at least it seams that things might be fixed someday 🙂

I Plan to Stick Around
Posts: 18

Re: Galaxy S2 LTE not receiving calls on LTE network


@lubiya wrote:

That's good news. Thanks for the update OMF.

 

Right now I tested my phone and I managed to receive calls while on LTE!

I'll still test it for few more days to make sure it works fine, but at least it seams that things might be fixed someday 🙂


Testing last night and this morning, I don't notice any improvement in Ottawa West/Kanata/Sittsville, along the Ottawa River Parkway, or in Gatineau.

 

I have always been able to make/receive calls while in certain locations.... my office in Ottawa East/Gloucester for example, where I can stay connected to LTE all day (albeit at relatively low data rates) and make/receive calls without any problem.  Other locations I may not be able to make a call while connected...despite the phone saying there is service.  And of course there are those areas where the phone reports "No service" or "Emergency calls only" where the phone refuses to make a call.

 

Where I am at the moment, in Gatineau, if I turn LTE on, the phone quickly switches to "No Service".  However, if I select GSM/HSPA.... I can connect via HSPA+ and make calls with 4 bars of signal strength showing.   Other locations I have to choose "GSM only."

 

In summary... the behaviour is very location specific... although I find it consistent in those locations.

 

 

I Plan to Stick Around
Posts: 10

Re: Galaxy S2 LTE not receiving calls on LTE network

Last night I called Rogers for an update only to be told that the interaction ID I was given was not escalated and nothing had been done. Disappointing. So I asked for a supervisor and explained everything to him again. He said he would talk to tech support and escalate the issue.

 

I spoke to tech support and got a callback within an hour from field tech support. they had me run some tests and the updated results so far are:

 

I now see 1 bar LTE in Bridlewood. while on LTE I can surf and UL and DL speeds are very low. But while on LTE, I can not make or receive phone calls. If I change the phone to GSM/HSPA+ i can surf and make or receive phone calls.

 

So the problem in Kanata appears to be partially solved. they said it was probably late in the evening (7ish) and they would continue to troubleshoot the issue tomorrow (today) and would get back to me to run more tests.

 

 

I Plan to Stick Around
Posts: 21

Re: Galaxy S2 LTE not receiving calls on LTE network


@rezadue wrote:

.... So the problem in Kanata appears to be partially solved. they said it was probably late in the evening (7ish) and they would continue to troubleshoot the issue tomorrow (today) and would get back to me to run more tests. 

_________________________________________________________________________________

 

UPDATE 2:

 

On my way from west to Kanata on March Road to North Technology Center the LTE system and the Samsung Galaxy S2 LTE worked fine now, for the first time! DL speed range is 20-28 Mbps, UL 3-8 Mbps. It means they have identified the problem and fixed it, so we don`t have to return our phones... I can imagine it may take some time to roll out the fix and verify it network wide.

 

I would like to express my appreciation to all of the contributors on this forum, Rogers Tech Support, Configuration Management and Field Technicians involved in the solution.

 

The lesson Rogers management should learn from this is there is a room for improvement in internal communication. Escalation of a network wide problem shouldn`t take a month to reach the appropriate level.

 

Anyway, I am satisfied with the outcome and waiting for the expansion of the LTE network. Smiley Very Happy

 

 

 

I Plan to Stick Around
Posts: 18

Re: Galaxy S2 LTE not receiving calls on LTE network


@rezadue wrote:

 

I now see 1 bar LTE in Bridlewood. while on LTE I can surf and UL and DL speeds are very low. But while on LTE, I can not make or receive phone calls. If I change the phone to GSM/HSPA+ i can surf and make or receive phone calls.

 


I just had voicemail left from Rogers (my phone didn't ring....surprise), saying that they've had technicians working on the LTE/HSPA issues in the "general areas of Ottawa" in the last few days, and that the problem should be "cleared / much improved."

 

I called them back from a land-line and said "nope, no go", that I'd seen the same issues at home this morning, on my commute to work, and sitting at my desk.  In fact this was while my phone was connected to LTE (2 bars, 4.75Mbps up, 10.21 Mbps down) and showing "No Service".  After a about 10 minutes my phone decided to change it's setting to "GSM/HSPA (auto)" and dropped down to HSPA and started showing service and 4 bars of signal strength (2.85Mbps down, and 1.03 Mbps up, just for comparison.)

 

The next call from them should be more interesting.

I'm a Trusted Contributor
Posts: 902

Re: Galaxy S2 LTE not receiving calls on LTE network

Man, that's CRAZY! Has anyone heard if BELL LTE is having the same issues?
Now on PPV