4G LTE not working on Samsung s6

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
CoastMtns
I've Been Here Awhile
Posts: 2

Re: 4G LTE not working on Samsung s6

So let me add some additional info:

My phone is Rogers not Wind/Freedom. It came from Rogers.

My signal shows as LTE, for the most part

My Model Number is SM-G920W8

My signal is terrible compared to others on the Rogers network

And the original message was as follows.......

Samsung S6 poor signal..always

I have a Samsung S6 Android Version 7.0

My "Network Mode" appears to be set as: GSM/HSPA/LTE (auto connect)

I am always having signal issues. My wife has an iPhone, also with Rogers, and she has no issues. The times I am having issues getting a signal she has no problems.

Any suggestions? Settings?

gp-se
I'm an Advisor
Posts: 1,143

Re: 4G LTE not working on Samsung s6


@CoastMtns wrote:

So let me add some additional info:

My phone is Rogers not Wind/Freedom. It came from Rogers.

My signal shows as LTE, for the most part

My Model Number is SM-G920W8

My signal is terrible compared to others on the Rogers network

And the original message was as follows.......

Samsung S6 poor signal..always

I have a Samsung S6 Android Version 7.0

My "Network Mode" appears to be set as: GSM/HSPA/LTE (auto connect)

I am always having signal issues. My wife has an iPhone, also with Rogers, and she has no issues. The times I am having issues getting a signal she has no problems.

Any suggestions? Settings?


@CoastMtns

I had an S6 for about a month when it first launched two years ago and experienced the same issues as you. I did some research and found out the phone uses a Samsung "Shannon" Modem instead of Qualcomm. I personally believe this Samsung designed modem has issues on the Rogers network. I currently have an S8 which uses Qualcomm and haven't had any issues, in fact the reception is better than my iPhone 6s that I replaced with the S8.

 

I would first make sure your phone is running the latest firmware, on the phone goto Settings -> Software Update

 

-Next I would backup the phone, you can use Samsung Smart Switch to back everything up to your computer.

 

-Reset Network settings, this shouldn't delete/wipe the phone, only the network settings:

  1. From a Home screen, navigate: Apps > Settings > Backup and reset.
  2. From the Reset section, tap Reset network settings.
  3. Review the info then tap RESET SETTINGS.
  4. Review the info then tap RESET SETTINGS to confirm.

 

-Some people say turning off VoLTE helps, you could try that too, it's in Phone Dialler Settings or Network settings, I can't remember exactly.

 

If that doesn't work then reset/wipe the phone and start fresh

 

https://www.androidcentral.com/factory-reset-galaxy-s6

 

Lanky
I've Been Here Awhile
Posts: 2

Re: 4G LTE not working on Samsung s6

Need some help. Both my wife and I have Galaxy S6. My phone wont connect to the LTE network. I can pick up 4G. I checked my network settings and they all seem to be correct. This just started today. Any suggestions?

RogersShaun
Moderator
Moderator
Posts: 319

Re: 4G LTE not working on Samsung s6

Hello @Lanky,

 

Welcome to the Community Forums and thanks reaching out. 

 

I can definitely understand the need to get on to LTE.  Have you tried any of the troubleshooting steps in this thread? Perhaps start with this post and let us know if you still have any issues.

 

Keep us posted!

 

RogersShaun

Lanky
I've Been Here Awhile
Posts: 2

Re: 4G LTE not working on Samsung s6

I have tried everything short of a factory reset. Nothing worked so far. Going to take it to a cell repair place and see what they can do.
gp-se
I'm an Advisor
Posts: 1,143

Re: 4G LTE not working on Samsung s6


@Lanky wrote:
I have tried everything short of a factory reset. Nothing worked so far. Going to take it to a cell repair place and see what they can do.

backup your phone then attempt the factory reset first.

 

Meowmix
I'm a Trusted Advisor
Posts: 32,103

Re: 4G LTE not working on Samsung s6

Hello @Lanky

Download Smart Switch on your computer and backup the device on that before you do the factory reset.

Once you do the factory reset, you are able to restore everything back onto the phone or pick what you want to restore back on the phone..

If that does not fix it, then at that point it would be best to get it check out. Maybe change the sim card as that could be the main issue too.