4G LTE not working on Samsung s6

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Meowmix
I'm a Trusted Advisor
Posts: 32,103

Re: 4G LTE not working on Samsung s6

Hello @braydonwoodbeck

Did everything work out? Hopefully Rogers did help you out 🙂 let us know 🙂
nnjetha
I Plan to Stick Around
Posts: 8

Re: 4G LTE not working on Samsung s6

See this:

 

http://forum.xda-developers.com/galaxy-s6/help/sm-g920w8-option-to-connect-to-lte-t3181839/post62425...

 

Issue with Wind phones.  I have to do this now as I'm running into the same issue.

dbane
I've Been Around
Posts: 1

Re: 4G LTE not working on Samsung s6

When is there going to be a fix to this issue ?

nnjetha
I Plan to Stick Around
Posts: 8

Re: 4G LTE not working on Samsung s6

I just "fixed" my phone yesterday following the instructions that were on this thread.  I dont think Wind is going to change this on their phones anytime soon unless their whole network starts supporting LTE.  The instructions below fixed the problem rather easily but wiped all the data from my phone.  

 

Prior to doing this I used Samsung Smartswitch to back up my phone.

 

 

@polishpat wrote:

Power off device, take out sim and power on. Ignore the no Sim message and then boot in safe mode as below

 

How to boot in safemode:

 

Power off phone, let stand for 1 minute. Turn on the phone by pressing Power + Volume Down, once the screen lights up, you can release the Power button but keep holding Volume Down until you get to lockscreen. 

 

If succesful, you should see a Safe Mode stamp on the bottom left. Once that's done, try going into settings and see if the LTE is available in network mode. If not, try manually selecting Rogers as a network operator.

 

If all fails, boot back up normally and try changing CSC to Rogers. First get your IMEI and write it down by pressing *#06#, then press *#272*YOUR IMEI HERE# and click RWC and click Install. This will factory reset your phone so make sure to backup before.

Forgot to mention to put your sim back in before booting in safemode

Mediaman
I'm a Reliable Contributor
Posts: 112

Re: 4G LTE not working on Samsung s6

@polishpat ,  @nnjetha :
 
I too am stuck on 3g. So I think I may need to do the same safemode trick. I have an older Samsung - an unlocked Wind phone (Samsung Core LTE SM-368W), now  on my Rogers plan - all is good except for the 3g issue.

Re the note "Forgot to mention to put your sim back in before booting in safemode", I just want to make sure I have the sequence correct. Is the following the correct sequence? :
 
1) Back up your phone using SmsrtSwitch
 
2) Power off device, take out sim
 
3) Power on. Ignore the no Sim message
 
4) Power off phone, let stand for 1 minute.
 
5) Put the SIM card back in. <<<
 
6) Turn on the phone by pressing Power + Volume Down, once the screen lights up, you can release the Power button but keep holding Volume Down until you get to lockscreen.
 
7) If succesful, you should see a Safe Mode stamp on the bottom left. Once that's done, try going into settings and see if the LTE is available in network mode. If not, try manually selecting Rogers as a network operator.
 
😎 Power off and restrat normally, 4G/LTE should now appear in the status bar.
nnjetha
I Plan to Stick Around
Posts: 8

Re: 4G LTE not working on Samsung s6

I would forget about safe mode.  It didn't work for me.  These are the steps I took

 

1. Backup phone with Samsung Switch or in your case maybe Samsung Kies

2. Get your IMEI and write it down by pressing *#06#

3. then press *#272*YOUR IMEI HERE# and click RWC and click Install

4. Turn on phone and restore from Samsung Switch

 

So far so good with my galaxy s6 edge

Mediaman
I'm a Reliable Contributor
Posts: 112

Re: 4G LTE not working on Samsung s6

@nnjetha 

 

Thanks. Sounds pretty good. Doing my backup now. I am using SmartSwich. (KIES was too old for my model).

 

Forgive my ignorance, but do I assume you type in the #272 sequence from the Phone keypad???  and then it will produce a "RWC" prompt??

nnjetha
I Plan to Stick Around
Posts: 8

Re: 4G LTE not working on Samsung s6

Yes.. the #272 followed by your IMEI as mentioned before right from your keypad.. you will see a screen that will allow you to select RWC.. 

Mediaman
I'm a Reliable Contributor
Posts: 112

Re: 4G LTE not working on Samsung s6

I know my IEMI,  and double checked it with  *#06# . All good. It also displays /08 at the end. Is that relevant?

 

But when I enter   * # 2 7 2 * followed by my IMEI and # , I get nothing .... no prompts.

 

Do I also need to enter the  "08" at the end of my IMEI?

nnjetha
I Plan to Stick Around
Posts: 8

Re: 4G LTE not working on Samsung s6

No it sounds like you did it right... might be your android version.  i am on 5.1.1.  Maybe you need to update.  Not sure I can help you out much further, sorry.