ZTE MF-275R Rocket Hub won't work with LTE (4G only)

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Here Awhile
Posts: 2

ZTE MF-275R Rocket Hub won't work with LTE (4G only)

Hi,

 

Last week I picked up the ZTE MF-275R Rocket Hub because my old hotspot doesn't support the rural LTE Rogers has deployed here in Saskatchewan. Unfortunately, I'm having a problem with it.

 

It won't stay connected to LTE.

 

Well... I learned a bit more this week. It will work fine on LTE - with SaskTel (on a SaskTel SIM). However, it won't stay on Rogers LTE for more than a few seconds before popping back down to "4G" HSPA+.  Even with the SaskTel service, the LEDs on the device change back to green every once in awhile, so I'm not sure it's entirely locking on LTE here, but it's making a better effort at least.  (The web portal for the device shows solid LTE, at least as far as I've known, when using SaskTel.)

 

I was in Medicine Hat, AB for the weekend and took the hub with me to see if the same problem exists there... and it does exactly the same thing. Every minute or so it will go to LTE for about 2 seconds, and then it hops back down, where it stays until the next attempt.

 

Meanwhile, back in Regina, on SaskTel, it takes a minute or two but it locks onto LTE and stays there (notwithstanding the LEDs popping back to green once in awhile for a moment).

 

I have two theories:

  • the device simply isn't working on certain LTE bands. It's difficult to know what band it's working on now with SaskTel, so it's hard to rule this in or out.
  • the SIM card isn't working properly. I changed SIMs on the Rogers account last week because the Rocket Hub needs a micro-SIM (and my old one was mini-).  I put the SIM into an adapter and back into my old wireless hub (Sierra 763S) and I do have LTE with it using my new SIM card, just as I did with the old one.

Any ideas or suggestions?  I'm guessing this points to a defective Rocket Hub.

 

I bought it at the Southland Mall (Gordon Road) Rogers kiosk in Regina last week, out of contract (paid for it in full).

 

Thanks!

 

Jim

 

 

***Edited Labels***

Moderator
Moderator
Posts: 852

Re: ZTE MF-275R Rocket Hub won't work with LTE (4G only)

Hey @PhotoJim

 

Welcome to our Community! Thanks for making the jump over from Reddit. Smiley Happy

 

We'll have to deal with this issue in private so please PM us @CommunityHelps so that we may proceed forward and find a solution for this. If you're not familiar with our PMing process, you can find instructions here.

 

Regards,

RogersCorey

What's New
Topic Stats
  • 1 reply
  • 1877 views
  • 0 Likes
  • 2 in conversation